Open Cutlist dimensional cross section

I have created an outdoor table with all parts being 2x4’s. I’ve used a common material color for all 2 x 4 parts with a single length of 10’ to use. When I generate parts list, OCL flags the cross section of a few parts as being 1.50001 x 3.50001 or a similar minor discrepancy which doesn’t allow for the cutting diagram to take all parts into account for using 2x4x10. I’ve changed the precision to less precise (which is set to fractions) but that still doesn’t account for all the 2x4 parts.

It’s not so easy to describe, thanks for any help.

Share the model so we can see exactly what you’ve got.

You should probably be increasing display precision so you can see what the error is and fix it.

That doesn’t help. For example, a single 2x4 upright OCL flags as not being 1.5 x 3.5, but changing to max decimal precision in sketchup and highlighting the edges shows exactly 1.5 and 3.5?

OCL isn’t reporting the edge lengths. It’s reporting the size of the component bounding box.

Meaning the some parts are off axes slightly?

Possibly. Possibly stray edges.Possibly something else.

I ran cleanup 2, I’ll check to see if things are off axes, thanks

Good luck. Have a good evening.

If this can be of any use, see this SU file with profiles from 2x3 to 2x12. Pull any of these to required length.

Standard north american wood beams profiles.skp (247.0 KB)

So I’ve found some unexpected dimensions or actual incorrect behavior maybe.

As I stated before OCL flagged some parts of a table I’m modeling as not being 1 1/2 x 3 1/2 or actually 1.50000 x 3.50000. I modeled fractionally to 1/32"

I tried re-drawing a simple 2 x 4 upright with the dimensions maxed out in decimal.
drawing 1.500000 x 3.500000 x 16. I then drew lines across guides I had placed and pushed pulled the unwanted remainder away and voila…the push pulled end now had a different thickness?

What face did you use Push/Pull on? The triangles to cut off the corners? Maybe like this?

push

You still haven’t share the SketchUp file as requested 2 days ago.

Not exactly like that

This time the new part had an end depth of less than 1.5
Garden Table.skp (75.3 KB)

Somewhere there’s a problem in the way you are adding the edges on the top surface. Note that even without Push/Pull you have a different height.

I drew the 16 in. long 2x4 and then added the edges on the top without changing the thickness of the piece.


After Push/Pull the height still hasn’t changed.
Screenshot - 6_11_2024 , 5_56_24 PM

It would be interesting to see what your actual process is for getting those edges created. Any chance you can do a screen capture video of it?

I’ve not tried a screen cast before and probably won’t make this my trail run. Thanks for looking at the file, I know now where the problem starts…sort of. Thanks again

Good luck sorting it out.

I noticed the widths of the angled parts of your table have strange dimensions, too. I wonder how you are modeling them, as well, because they should be 3.50000 wide.