Offset Tool geometry issue

Hi All,

I’m having an issue with the offset tool (or my workflow) which is causing errors in my model. I’ve modeled a 2d profile with lots of curves on it and have pushed it so it has thickness (10mm). Now, I need to create an irregular “bevel” (please bear with me here before you start telling me to use “follow me”) in the model.

“No problem” I thought, "In Lightwave 3D, I would just click on the face, press “shift-H” (smooth shift), then “n” (numeric) and enter in my offset and my inset. Then I would push and pull edges to take care of any irregularities or to create the uneven bevels.

So, I tried to do that in Sketchup… I clicked on the face, Offset by 10mm (tried tried it with both “allow overlap” on and off), clicked on the resulting face, and then moved it vertically by 10mm… and this is what I end up with, :frowning:

I’ve checked that my model is solid, it doesn’t have extra hidden edges anywhere… it just seems like SU is just messing up the order of the geometry during the offset and so it’s not generating the appropriate profile for the “bevel”.

Note: I would love to be able to offset 0, then move the resulting face up and then scale and then move some edges around, but you can’t offset by 0 either :slight_smile:

I’ve checked:

  • There are no extra edges in the model - it’s just one long continuous edge
  • The number of segments for the rounded edges is the same (12) for both levels of the model
  • Deleting the “bad” hidden geometry and manually drawing in lines in to replace the bad geometry - this comes closest to doing what I need but it’s a ball ache and some of the faces don’t show up when I draw them in

Btw, this is what I’m trying to model…

I would recommend posting the model (.SKP) to start. I can think of a couple ways to get what you are looking for, but it would be easiest to look at what you’ve got, first.

In Sketchup you can’t have multiple edges and faces in the same location in space in the same context.
You would have to pull up a copy of the desired face (hit [Ctrl] once when pulling the face up to get this copy, leaving the original face behind), then scale the copy face. The result would be the same. Maybe not as expected. But this is the right order.

Better yet, scale up your model and use ‘Follow Me’ to create the bevel along the entire perimeter. Scale down the result again when done.

I’ve moved past the issue by deleting each wonky edge and replacing them with appropriately ordered edges (and the making them “soft”. Of course now that I’ve done that, if I want to “bevel” it out again, the next section goes all wonky again, so I’ve just given up on trying to make the model actually look like the real thing and am cutting out all “bowed” surfaces. :slight_smile:

Either way, here is the skp that I’ve got so far - the offending surface is on layer “saw base”.

Bosch GTS 10 XC.skp (520.3 KB)

PS - another thing I would love - a thickness/hollow/skin plugin that, given a “thickness”, hollows out a solid an d makes a skin that thick from the solid.

Thia is not a problem with Offset Tool but a problem in how Move Tool splits faces. Often it gets it right but sometimes this happens. It would be nice if this tool could be tweaked to prioritize new edges between closely positioned vertices.

1 Like

There are some options for that but maybe you just need to change the method for drawing the base. Draw the cross section and use the outline of the base as a path for Follow Me.

1 Like

Indeed. Thanks for the help.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.