Offset Limited To 0.65m Error Message When Trying To USE Push Pull Tool..?

Some of you may remember that I’ve been working on corridors for a game and was having problems with the Follow Me tool which got sorted out thanks to the kind help of some people on here.

And here I am again lol

I decided to start again because a couple of the circles I used for my template had the same problem that my arcs were having (the arcs needed to be rotated because they weren’t square to the template). A couple of them weren’t square and needed to be rotated 7.5 degrees otherwise one of the turns on my T-junction was off. I also wanted to increase the scale because I found that the models needed to be A LOT bigger firstly because 1m in SketchUp is the equivalent of 1cm in Maya and Unreal.

So my plan was to end up with this:

with correctly placed quarter and semi circles. So I was going to create the rectangle, make it a group and then add my circles and rotate them all 7.5 degrees. Then Explode the group and finish the template. I’ve changed the scale by multiplying my previous values by 100.

But then I came up with a problem I didn’t have before. Using the Push Pull tool to extend my corridor out so that it was 200m long worked fine, no problems. But when I tried to extend the side walls out 30m I got an error message saying ‘Offset limited to 0.65m’ shown in my second post.

And when I tried again it worked fine and allowed me to extend that face.

So I thought me using a group was doing something wonky somewhere and started again right from the start with a New project. I drew the 6 circles, rotated them all and then drew the rectangle on top so no group needed. And I got the same error message again.

I didn’t have any problems at all before so something has gone pear-shaped somewhere with me using a larger scale, perhaps…? The thing is that I haven’t done anything different with the dimensions of the model apart from multiplying everything by one hundred, and my corridor template is now 1m thick rather than 0.01m. And if that 1m offset is a problem then why didn’t I get a problem when I extended the corridor out…?

Just wondering what’s causing this to happen,and also if I just carry on regardless and ignore the error message and just use the Push Pull tool afterwards whether this is going to cause me problems with something else (such as modelling my turn, t-junction and crossroads using the template or even issues in the Unreal Engine later on down the line…? :worried:

Many thanks in advance for any help! :smiley:

A bit daft I can’t post more than one image :frowning:

Here’s the error message I’m getting:

Your second image has a ridge rather than a valley in the side. What I think is happening is that the first segment of the ridge’s arc is perpendicular to the side. Pushpull can extrude along that segment, but doesn’t know what to do when the next segment isn’t perpendicular to the side so it limits you to there:

1 Like

Brilliant! Well spotted! Thanks ever so much for that! So if I do this again and don’t rotate the circles at the side I should be good to go. Thanks a lot for your help! :smiley: