Objects or edges not inherently locking to axis when i move them

Hi there,

I dont know what happened to my sketchup model but i used to be able to move objects and edges in a straight line, whether it be the red, green, or blue axis, without using the arrow keys to lock the object to a specific axis. But now now i cant do it anymore. When moving objects or edges from a top parallel projection view they dont auto lock to an axis.

I tried creating a new file and the inherent axis constraint works but for my old file it does not. I’m pretty sure its a setting of some sort that i toggled off but i cant seem to be able to figure out.

I am using sketchup for web paid version.

Any help would be appreciated.

Thank you.

Please share that “not working” file for others to look at.

I stripped down the file and left a square from the top view to manipulate. As you will see there is no way of moving the edge or the entire square in a straight line. Its supposed to automatically lock to any axis and then release if you deviate it too much, all without using the arrow keys to lock it to any specific axis. I dont know why its doing that. The auto locking only works if i move the object up or down along the blue axis but not along the red or green axes.

A 064.skp (13.6 KB)

Thank you.

I find no issues with moving things in your model, I tried it in both Web and Pro.
I note that the axis has been moved, that may be significant and perhaps resetting it will solve the issues on your end.
I would also turn off length snapping, it tends to cause errors.

All directions seem to be working as should: constrained to line when locked either by [Shift] or by [Arrow] keys. (some cursor info show as being “Constrained on line” some show as “On Red/Blue/Green axis”).
So nothing wrong on this end. Only the moved axes as @Box already mentioned.

What axis are you talking about? I tried creating a new file and the problem persists.

It’s working now. What i did is placed the axis on the center of the scene and then saved the file and restarted it. I guess that fixed it or it got fixed on its own.

Thanks guys.

I think that’s a typo and that @Box meant axes (plural), not axis. You can reset the axes to their original location.
Right click on an axis and select ‘Reset’ in the context menu.

I think saving and restarting (re-opening) the file fixed the issue rather than placing the origin (axes) in the center of the scene.