No snapping, rotating, scaling

I recently updated to 2024 on Mac Pro 16 ( 2,3 GHz 8-Core Intel Core i9) running on Sonoma 14.4.1 it looks like after a short while I cannot snap to endpoints, no rotating tool, no scale. So far the only way to reset is to close the file and reopen. Quite frustrating. Has anyone else experienced this? Any possible solutions would be greatly appreciated. Thanks

Is this with the new graphics engine or with the classic graphics engine?

Please update your profile. It’s way out of date.

I havent used the graphics engine yet. will update the profile

You must be using one of the graphics engines in order to use SketchUp.

I meant, havent used the new one yet

So you selected the classic graphics engine in SketchUp Settings?

no idea, let me check …

oh, it is the new engine one selected

Are you still using an Intel Mac with AMD GPU? There is an issue we’re investigating, where on M3 Macs the model window can stop updating. You can do a save, close, open again, to get back into action, but it is likely to freeze up again a while later. Choosing the classic graphics engine is the only work around for now.

1 Like

Thank you, I changed to classic graphics and so far no issues.

This sounds similar to an issue mentioned here:

Same issue here
Im on a Mac w/ Apple M3 running Sonoma and Sketchup Version 24.0.483.
any input?? It’s super annoying having to close the program and open again every few minutes.


I see this regularly when models get larger, both in 2023 and now 2024. Try clicking on the desktop to activate the Finder then clicking back onto the SU window to activate SU again. This seems to clear it up for me when it happens. Clearly a bug in either SU or Apple’s window events.

Thanks. I’ll give it a go. Of course, when you want it to stop working, in order to test your suggestion, its working just fine :-/