No 3d display on Dell XPS 15 9550 using NVIDIA GeForce 960M


#1

Hi,

I have a Dell XPS 15 9550 and have been using SketchUp quite successfully using the integrated Intel graphics card. I recently wanted to switch to using the dedicated NVIDIA GeForce 960M but when I run it with that card the 3d area is blank. Toolbars etc are fine. I have tried fiddling with lots of settings in the NVIDIA control panel but nothing helps. No errors are reported etc. I’m using the latest drivers from NVIDIA but have also tried those listed on the Dell website.

SketchUp preferences shows that the correct card is being used with OpenGL version 4.5.0. Others seem to have no problems with this laptop, so… why me?

Any suggestion?

  • Tim

#2

Slight update, I installed a program called RenderDoc, which among other things can capture images from an OpenGL context. You may see where this is going…

Even though SketchUp is displaying nothing, I can still manipulate and draw (though slightly blindly!!) and RenderDoc can capture what SketchUp should be showing. So everything appears to be working correctly, except SketchUp just isn’t displaying it. Note, it works absolutely fine when the integrated Intel card is used.

Strange.


#3

Just some things to check:
In the Nvidia control panel 3D application settings, things like Antialiasing and Anitotopic Filtering should be set to “Application controlled”.
Is your display set to True/Full colour? I have an older Lenovo laptop that has an annoying habit of switching to 16-bit colour when I connect it to its dock. SketchUp requires full (32-bit) colour.

Anssi


#4

I have switched everything I can to “Application controlled” with no effect. It seems Windows 10 no longer supports 16-bit colour, I think, at least all the settings I can find, and my eyes, suggest it is 32.

Also, the SketchUp Checkup app says that everything is okay and I can’t see anything unusual in its log.

  • Tim

#5

Did you upgrade to Win 10?
I have found that Win10 refuses to use the Nvidia card even when you tell it to.
I rolled back to win 7 on my laptop with that card.


#6

It was a fresh install, but yeah. The card works fine in other 3d applications, games etc. Sketchup is using the card - the “NVIDIA GPU Activity” monitor says it is and as the screenshot above shows, I can interact with the 3d window as normal. I just can’t see it!

If I had to guess, I would say it is something to do with the dedicated card having to pass through the integrated to display to the screen. Though other apps manage this fine and I can’t see that others are having a problem with this in SketchUp.

I am stumped.


#7

Update (rollback) driver?

Use multiple monitors?

Try running SU in clean boot to rule in or out interference from another app.


#8

You must also restart SketchUp after making any changes in the OpenGL panel of the Preferences dialog.

You could install SketchUp 2016 as a test (but “Repair” the 2017 installation after running the 2016 installer to reset the IE browser emulation to v11.)


#9

I couldn’t use SketchUp 2016 because the trial had previously expired. I did install 2015 though, both 32- and 64-bit, and nothing changes - it works using the Intel card but not the NVIDIA.
Ho hum.


#10

I’ve got the latest driver installed, I have used a few older ones in the process of trying to fix it - installer newer ones as they’ve been released. I suppose I could try a much older driver… a job for tomorrow.

Also, I’m not using multiple monitors and a clean boot didn’t fix it.


#11

You need to install Make edition not Pro (once a trial of that version has expired on a machine.)
And there is a special download page for non-current Make versions:
http://help.sketchup.com/en/article/60107


#12

Okay, SketchUp Make 2016 32- and 64-bit don’t fix it.

I have also installed the earliest NVIDIA driver I can find, from 2015, one from early 2016, the one currently supplied on the Dell website, and back to the very latest. No effect. I have also tried updating the Intel drivers to the latest supplied by Dell, and by forcing an install of the latest from Intel. Again, no luck. In both cases trying 32- and 64-bit version where available.

I think It’s time to give up!


#13

When you installed SU, did you r-click on the installer > Run as administrator?


#14

Might as well post the “.sulog” file from Checkup.

And check the WER folders for any application error reports. (You can do it via the Event Viewer if you wish.)


#15

Its seems that your card is absolutely right but there is something wrong with resolution settings of your system. As mention in Dell XPS 15 Manual to customize it just do:

  • Go to Control Panel > Display > Settings/Personalise

  • locate the Resolution dropdown box and then select the resolution that is correct for your screen

  • Once you’ve selected a new resolution, Windows will give you a preview of what your new screen settings look like. If you’re happy with them then select Keep. If not then click on the Revert button - or you can wait 15 seconds and it will automatically reset itself to the previous resolution.