New "Super System" crashes 2-3 times a day!


#1

OK…so I moved over from Mac because Mac is not as powerful as what I can get for half the price on PC. So I reluctantly moved over. My last foray into the PC world was about 12 years ago, so bear with me.

But - is this “still” the world of PC’s after this long time? Blue screens and SketchUp crashing several times a day? I HAVE to be doing something wrong.

Here’s my “super” setup that I spared no money on:

Intel Core i9-7960X (16 core) - NOT Overclocked
ASUS Prime X299-A ATX
64GB Corsair Dominator Platinum DDR4 3200 (using XMP in Bios)
Drive 1 - Samsung 1TB 960 EVO m.2 NVMe SSD
Drive 2 - Seagate 4T BarraCuda Pro 7200 SATA III
EVGA GeForce GTX 1080 Ti SC2 Hybrid Gaming (Not overclocked)
Corsair RMx Series RM750X 750W PSU
Corsair Hydro Series H115i PRO RGB CPU Liquid Cooler
ASUS MG28UQ 28" FreeSync 4K Monitor

So - I did a lot of research and decided on these components based on being some of the best equipment available to build my “super” PC.

I didn’t touch any of the overclocking since I didn’t want to mess with a good thing! :wink: Only thing I did in BIOS was change memory to XMP to reach as high as I could.

Using SketchUp Pro. Have V-Ray Pro loaded. Here are the Extensions I have loaded:
1001bit tools
CLF Shape Bender
Fredo6 Curviloft
Fredo6 LibFredo6
FredoScale
Fredo6 Round Corner
Profile Builder 2
Selection Toys
Layers Organizer (which looses all it’s folders when SketchUp crashes!!!)

So - I am begging for help. How do I make this system more stable? I just installed the system this past week, so all is a fresh install.

I uninstalled SketchUp today in the hopes that it would work better once I reinstalled from Administrator as some posts have suggested. I have screen magnification to 150%.

I’d be wiling to clear everything out and start from scratch if it will help my system.

Another big annoyance - I ordered a MiniDisplay Port cable to hook up my old 2009 iMac as a target display for the PC. Worked absolutely wonderful the first time I hooked it up. Decided to rearrange my desk and unplugged everything and rehooked everything up - now it doesn’t work???!! Literally did NOT change any settings, just unplugged, moved and reconnected everything. Can’t figure that one out either. Already tried unplugging monitors and tried all port arrangements to no avail. Little help online.

OK—it’s turning into a vent. But really, if anyone could help I would be eternally grateful.

Cheers!


#2

Nvidia control panel> manage 3d settings>Global settings>OpenGL rendering GPU - set to your 1080ti
Next tab
In Program settings Select Trimble Sketchup check to see if the OpenGL rendering GPU is set to your 1080ti
This should be a starting point.


#3

When you re-install, be sure to do it as follows: 1) Login as your normal user account. 2) Right-click the Installer EXE and choose “Run as Administrator”. Do not log into an Administrator account and simply Run the installer EXE. That combination is not equivalent to the other.

It may be that the subtle and amazing issues arising from an incorrect installation will explain the crashes. But if not, I would suggest disabling ALL extensions (or as many as you are able to technically disable), quitting, and restarting SketchUp. Then run a few SketchUp sessions - not using any of the disabled extensions, of course. If you still experience crashes then it’s not the fault of the disabled extensions. If you do not experience crashes, then it’s moderately likely that one or more extension are to blame. You might check for updates to these extensions. The Extension Warehouse has a build-in mechanism for doing that, in the case of extensions obtained from the Extension Warehouse.


#4

Thanks TDahl - followed your other links to installation and did that. I only have the one account on this system so far and right clicked the installed and “Run as Administrator”. Still issues.

All extensions are updated. Turning off most of them and restarted computer to try again. Will let you know if it makes a difference.

Thanks for the quick response guys. Going to double check Nvidia settings but think I already did that.
Also - just as an aside- I tested the system with Aida-64 and everything is working fine according to it. Temps are great also.


#5

Hey RLGL - I guess my noobishness is bad. Only app from NVidia is GeForce Experience and nothing there. I went there after going to the Device Manager and clicking on NVIDIA from the display adapters. Can’t find anything in that panel that says 3D settings.

Can you help telling me where to find that? (still getting confused at the difference between “Computer Management”, “Control Panel” and “Device Manager” lol).


#6

Right click on the desktop, it should be in the context menu " Nivdia Control Panel"

No Worries


#7

Thanks guys. I started by getting rid of all the extensions except for base and V-Ray. After a restart of the computer, still had bad problems. Would get the blue circle every 4 or 5 minutes and would hold me off for about a minute or so. Saving the file would take 3 or 4 minutes. Not a large file so I was stumped.

Out of frustration I decided to go down to the bare bones of the file to see if it was the file itself. Deleted everything except for the frame (to a small unit). Was still having the problems even after purging everything and getting rid of all surface materials and changing them to default! Was pulling my hair!

Decided to just copy the entire structure and paste it into a new SketchUp instance. That did it! Saved in 2 seconds and more responsive! So I went back to my original model and did the same thing, copied the entire structure and pasted it into a new file. So far it is working just fine after 4 hours.

So there must have been something wrong with that file. I had rebuilt the whole structure this week, so the only variables where the extensions I’ve added. Wonder how an extension, even after being turned off, would leave “residue” on a file and bog it down like that. Maybe something I did - who knows!

Anyway, fingers crossed that it stays like this. I’m optimistic in how it is responsive and hasn’t crashed in that time. I’ve created a folder that I call “Protected” now - leave a version of it when its’ working great.

Thanks for the help. Cheers.


#8

check with your orig. document if unhiding all and switching all layers visible reveals additional elements.

Geometry very far away from the model origin (e.g. after a DXF/DWG import) may bog down the SU performance too, move to the origin for fixing this.


#9

Vray will add a lot of attribute data especially attached to materials.

So, model smartly. Model with shading only so you can tell which direction the face normals point. (Front of faces outward, back faces inward.) There are help articles about best performance modeling techniques.

Disable Vray while basic modelling and switch it on (and style to shaded with textures) only when ready to attach Vray materials and render. (Ie, get all the basic geometry correct first before painting and rendering.)

Control Panel is the basic window interface to most things regarding technical control of your computer.
The icons in this window represent .cpl files called control panel applets. (Third parties can create control panel applets that appear here. Examples are mouse OEMs and other hardware peripheral companies.)

Device Manager is a control panel applet which gives access devices and allows updating their drivers, checking if they have memory conflicts, etc., etc.

Microsoft Management Console (MMC) is an applet interface that uses paned windows often with a navigation frame on the left. The Administrative Tools control panel applet is simply a window displaying shortcuts to various MMC “snap-ins” that allow administrative tasks. One of these icons it displays is a Computer Management “snap-in” which has among other things a Disk Management applet to partition and control hard drives, etc. Computer Management also allows access to Device Manager and perhaps several other things accessible via Control Panel.

Basically there’s multiple paths to the same applets. Some have been left for historical reasons. Ie, at one time there were 2 basic editions (DOS and NT) of Windows which merged into one NT edition called XP. So since then we’ve had both the consumer grade and the more geeky NT interfaces, with both access paths.
You can also bypass these window interfaces and get right to the applet you need if you know it’s filename, by entering it in the StartMenu > Run box.

Control Panel
          |
          +-- Device Manager
          |
          +-- Administrative Tools
          |                    +-- Event Viewer
          |                    +-- Performance
          |                    +-- Task Scheduler
          |                    +-- Services
          |                    +-- (other shortcuts)
         (other applets)       +-- Computer Management
                                                   |
                                                   +-- System Tools
                                                   |       +-- Event Viewer
                                                   |       +-- Device Manager
                                                   |       +-- Performance
                                                   |       +-- Task Scheduler
                                                   |       +-- (other applets)
                                                   +-- Storage
                                                   |       +-- Disk Management
                                                   +-- Services and Applications
                                                           +-- Services
                                                           +-- WMI Control

If the access hierarchy is confusing, you can create shortcuts to these applets and arrange them for access that makes sense to you. (ie, in a group on your desktop, or in a folder on your desktop, in a toolbar docked to the side of a display, in a submenu of the StartMenu, “pinned” to the StartMenu … the options are many.)

The drivers that come with video cards are going to be behind somewhat. Download and install the latest driver from Nvidia website. Experience will do it, but it’s really a rigmarole (and slower) compared to just downloading the installers manually, that I uninstalled Experience.


#10

Thanks guys. I’ll check on your suggestions. Happened again last night after I applied a mesh light in V-Ray.

I’m saving more carefully now so not a big issue. But again, copied and saved the unit into a new file and it works like new.

I was trying to find any articles about this and just came across one vague comments about doing the same thing but no explanation as to why. If anyone can point me to an article about it that would be great so that I can understand what is happening to avoid it. Crashes happen at random times and for random reasons. It’s not like it’s only happening during rendering. One time I’ll be rendering, another I’ll be zooming into a part of the model (like last night), another I’ll be moving from one part to another.

I’ve gone back and remodeled a few of the windows and doors that I downloaded from 3D Warehouse thinking these models have some issues in them. It just surprised me that I still had the issue last night even after all the Extensions being off all day except for V-Ray.

Thanks again for the patient help. You guys are great!


#11

Are you getting blue screens too, like you said in your first post? Did you build your system yourself? I wonder if the BIOS settings you mentioned might have a hand in this. Is there a safe but slow memory setting option you could try? Are other applications beside SketchUp crashing?


#12

Another thought, probably a long-shot: are you using text labels in the SketchUp model? There is an obscure bug within SketchUp related to handling text labels under certain circumstances. Just a couple of weeks ago I recall seeing a post that finally identified the circumstance, something like attaching labels to objects and then deleting the objects?


#13

Thanks again guys. Anssi - I really don’t recall since I’ve been loading all my software and such over the past 10 days since I built the system. I think it also crashed while messing around with Illustrator (blue screen). Had a couple of other instances where I got the blue screen, but definitely happened more in SketchUp. Hasn’t happened over the past 4-5 days though, so hoping for thing to have settled down (wishful thinking). Did a lot of research and fortunately JJ from ASUS had a 2 hour video on a system build very similar to mine. Even copied the order of drivers that he did since he said it was important. BIOS is stock except for the XMP that Intel and ASUS suggests and have not read of any issues with this board/memory configuration. If it keeps happening will definitely revert and try again. I might be tempted to do a clean install anyway since not having my 28" iMac as a second screen is a HUGE disappointment because I want to have both systems on my desk and not have to bring another monitor. I love my two monitor setup. Hate how it just stopped working like that. Oh well.

TDahl - interesting you mention that. I did have a label that I then deleted at some point. Also have dimensions - does the issue also happens with dimensions on the plan? So far the model has been working sort of ok. I’ve decided to split the file into the framing and slab in one file and the rest in another. Seems bizarre to me with a small building that is only 24’x9’ and only showing around 360K faces, but it makes it work a bit smoother. When it starts slowing down I revert to restarting the computer. Usually happens every 2-3 hours of solid working on the files for it to start experiencing this issue. Still working without any other Extensions except for stock and V-Ray.

Thanks again for the helpful comments. Cheers.


#14

lol…figures. Just after writing this email I worked on SketchUp for about 15 minutes and was changing scenes when I got the blue screen of death! Gaaaaahhhh!


#15

Maybe it is time to backtrack a bit. Get a copy of Memtest86 , and test memory according to the directions. One stick at a time and test all four slots on the board.
Also is the memory on the QVL list? Was it a matched set?
EDIT:
Do you have the latest BIOS version?


#16

BSODs are typically related to hardware problems (defective hardware, driver issues).

Install the ‘ASUS PC Diagnostics Tool’ and run the “Stress Test”.


#17

I apologize that it has taken me so long to respond. Just busy with a couple of concurrent projects.

RLGL - thanks for the suggestion. As I mentioned before, when I built the system I ran what JJ with ASUS did which was run Aida 64 and all memory and system passed the test. Having said that, I went with your suggestion and ran the Memtest86 and ran the 10:45 HOUR TEST!!! Holy Molly is that a comprehensive test! All passed with flying colors.

I’ve also gone with the suggestion to go back to stock memory and not XMP. While I haven’t had the system crash on me, I’m still having an issue with slow downs. I haven’t had too much time to mess with it and crash it, but enough to see a difference. I’m starting to narrow down the conditions. I can start feeling that V-Ray is the culprit. Now, in my model, when I run a quick render, the system slows down. I can always tell the immediate difference when I save the file. Before running a render with V-Ray the file will save in 3-5 seconds. After I do a render it takes 3-5 minutes! At that point the solutions is to restart the computer. It also happens sometimes when I go into V-Ray to add some textures. Still need to fine tune my search but I am narrowing it down to that so far.

My next step is to track down the V-Ray issue and see if there are solutions in that thread of throught. For now still frustrated that this “super” system still has to struggle with an application. Things just worked on the Mac. Even Sketchup, but it was just too slow to render. Never had the issues with file or crashing.

Thanks again for all the help. I am absorbing everything you are saying. Just takes me a little time to get to it.

Sketch3d_de - Next is to run your diagnostic tool. I think I did that when I built the system last week but never hurts to run it again. Thanks.


#18

Hey Sketch3d - I just looked at your link and could not find a link to download the file. When I did a google search for the file I get all these random download sites that I never trust.

Having said that, looking at the information and the manual, it looks very similar to the tests run by Aida64. And the fact that JJ from ASUS used it in his install tells me that he probably uses that instead. :wink:

I’ll try to run some more test. When I built the system I did all the tests he recommended including Cinebench and Aida64 and everything checked out fine.

Any other suggestions appreciated.


#19

seems that it has been discontinued… but, there is a recent BIOS upgrade to version 1301 from mid of March available claiming to “improve the system staibilty”:

Upgrading the BIOS has the potential to harm your system, do not power off regardless what happens resp. besides being told by the updater :wink:


#20

I don’t know much about V-Ray; does it run as an extension within the SketchUp process? Or is it running in a separate process? In either case, I would think that exiting (or killing) the SketchUp or the V-Ray process would restore normal performance. If a Windows reboot is really required, then V-Ray is doing something rather unusual to affect the system beyond the life of a single process. Maybe there is some kind of background V-Ray daemon or something? The Windows tools to monitor performance may reveal what process(es) are consuming cycles.