New Sketchup Shop license, Trimble Connect not working

I just signed up and paid for a Sketchup Shop license. I can’t save my first drawing, error connecting to Trimble connect and no way to save local. Stuck. Please help before I demand my money back.

In the mean time, use the Folder Icon and download the model to save it locally.

What browser are you using?

I’m seeing the same thing. Cannot log in.

You mean you tried in another browser?
Where did you bought the subscription?
It could be that it was not assigned correctly.
Used a different email address, to buy, for instance.

I can’t even get to the page to log into Trimble Connect. I have a SketchUp Pro license.

When I go to this page: https://connect.trimble.com/

I click on SIGN IN, and I get a spinning icon and the page doesn’t load.

I just tried to sign in and was successful. Can you try again and let us know? Thanks @DGinVT

I just got in! Thank you for checking.

1 Like

Good to know. Thanks!

Multiple browsers, still not working 24 hours later. Getting cookie errors. I am allowing tracking cookies for the site. For example:

A cookie associated with a resource at (google) was set with SameSite=None but without Secure. A future release of Chrome will only deliver cookies marked SameSite=None if they are also marked Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at (chromestatus)/feature/5633521622188032.

… and then:

Failed to load app.connect.trimble.com/tc/api/2.0/regions:1 Failed to load resource: the server responded with a status of 500 ()

Can you login to the 3D Warehouse?
3Dwarehouse.sketchup.com
Try to sign in on top right