Network license of SketchUp 2015 Pro stopped working


Our network license of SketchUp Pro 2015 just stopped working yesterday on all the machines it is installed on. I know it’s an old version, but it works for us and we have 3rd party rendering engine plugins that work for that version. If we upgrade, that means the whole office needs to upgrade both SketchUp and the 3rd party rendering engine licenses.

We have 2 standalone license versions that are still working just fine, but the network license stopped working. We have shut down all the computers that have the network license installed and then started just one up to try to get it working and still get the same error that the license is in use. We’ve restarted the server and checked to see if the ports are opened and everything seems to be in order. I cannot contact customer support as the maintenance plan has expired and I can only renew it at this point by purchasing a new license (I believe). Is anyone else experiencing issues with their 2015 Pro network license?

Are you sure that no one activated a newer version in the last 60 days?

(Did you ever received the serial and authorisation for 2016?)

No new activations that I know of. We have not received any serial or authorization for 2016 or above.

Is your network license still of the variant that runs via a folder in your local network? If so, there might have been a hiccup that left the reservations up (an user crashed, for instance). In that case you could try removing the contents of the license folder except for the actual license files (i don’t remember what the reservation files were called). Also check that the path to the license folder hasn’t changed and that the users still have their read/write permissions to the license folder in place.

Nice thought. However, 2015 was the first cloud-based Network License manager, so I think it checks with Trimble’s servers.

That is what my memory told me, but your mention of restarting the server sort of confused me.

Then, have you checked that something hasn’t gone and blocked the required network ports ( 5053 and 50530, according to the documentation)

1 Like

I asked because it is important to know if 2015 is still active…
What do you mean with ‘starting the server?’

yeah, I just mentioned restarting the server in case anyone asked that (and I wasn’t sure at first about the cloud-based network license management). I checked from the workstations in question and the outgoing ports seem to be open (connects just fine through a browser). Incoming ports are not open, however, as I don’t know how that would work since you would need port forwarding to work, but it’s multiple machines that would need the response (also nothing has changed on the Windows Firewall or business firewall recently that I am aware of).

It’s still active from our account as far as I know. I just don’t know if Trimble has called an EOL on their cloud license servers for the 2015 version. Was wondering if anyone else has had issues (would point to something on Trimble servers) or if it’s just me (would point to something on my end).

Thanks for all the suggestions!

Quite a few parts of stopped working for a little while yesterday. I wonder if that could affect network licenses?

I finally figured it out. It appears to be on our end (not on Trimble’s). It looks like SketchUp crashed while one of the users was in a model and for some reason, the file remained locked (and an Autosave version of the file remained locked as well) on the server, which continued through a server restart. I could manually move the locked original and autosave files into a subfolder via File Explorer and then SketchUp was able to open up again without issue. Still not sure how it happened, but wanted to post just in case someone else ran into a similar issue.

1 Like