Need help with scenes

I’m not an expert SketchUp Pro user and am having trouble with a simple task. I’ve built a model of a piece of furniture. I use layers to control visibility of items that are connected to each other. But I want to create a view of each component so I can print out a blueprint for the shop. I recall that Scenes can be helpful for this, but each time a I modify one scene, it changes all the other scenes. Is there a way to create 10 different scenes from one model that are each unique views of the model?

Can you share your SKP file so we can see what you’ve got. I’m sure we can get you sorted.

If you are moving the components in your model around, those changes are going to show in every scene. You can make copies of the components away from the assembled model and use those for the scenes to show the individual parts.

As an example here’s a view of the overall model space for a table I created for a plan.

There are 16 scenes showing different parts of the project. For example the aprons. The ones in the scene are shown above the assembled copy of the table.

And then those viewports are used to create the various viewports in LayOut where dimensions, labels and other text are added.

Crib rev2.skp (249.2 KB)
This is a work in progress. I recall seeing a tutorial awhile ago where you could get separate views in LayOut but it seems amazing to me that you can’t do that in SketchUp. Any advice is appreciated though.

You can get separate views in SketchUp. Those are called scenes.

The first thing I see in your model is incorrect use of layers. Layer 0 should ALWAYS be left as the active layer. All edges and faces should be created and left on Layer 0 and only components, groups, and dimensions should get assigned other layers.

I’ll repair your model and upload the result.

OK. I think I fixed all of the geometry. I created four scenes, a 3/4 view, front 2D, end 2D and a 2-view scene showing the end boards to give you an idea of the process. I didn’t do anything with the dimensions but if I were making plans for this piece, I would add them in LayOut instead of in SketchUp. I also didn’t do anything with materials but they should be applied to the faces in the components, not the component containers.
Crib rev2.skp (255.8 KB)

Some of your components seem to have some issues with off axis geometry which you should probably look into.Notice the dimensions in the cut list.

I’ve cleaned up your model so dimensions are more reasonable. I also fixed the materials. I don’t quite understand some of your joinery or the arrangement for connecting the platform to the bed frame. I will say, it’s built heck for stout. Who are you building this for? A baby gorilla?

Crib rev2.skp (510.8 KB)

Thank you! This looks great. So is the key using the combination of different views and hiding layers? Because when I tried creating two scenes that used the same view but hiding different layers in each the scenes would always synchronize and become identical.

It might be overbuilt; I’ve never made a crib before. The platform part of it under the mattress is not really done yet in the design, which is why it looks funky. But it’s also going to be a toddler bed so the rails can come off and the platform gets lowered closer to the floor. It’s a gift for a relative and I’m hoping it will get passed around in the family and get much use, so I’m going all out as far as durability with maple.

Sorry, I hate to be dense, but I keep having the same problem. I created an additional scene. I added in one of the posts off on the side and zoomed into it to get the view I want. Every time I go to that tab, though, it has the view of the endboards 2D scene. I can zoom all extents and rewindow it and see it. But then when I export Layout, the scene has changed again. There’s some small step, I imagine, I’m just not getting. While I totally appreciate the work you did on it, do you think you could spell out the steps to create a new, unique, durable scene or point me somewhere that’s explained better than in the Sketchup docs?

Just guessing, after getting the scene set the way you want it, are you right clicking on the tab for the scene, selecting update then saving the model. This process will prevent the scene from reverting to what is was when first created.

Have you found this VIDEO yet?

If layers are included as a property to save when you create or update scenes, their visibility will be based on how they were set when the scene is created or updated.

Here’s an overall view of my revision of your model. To get the 2-view scene of the end parts, I copied the components up and adjusted their positions to suit. I also turned off the layers for the other parts. You can see this if you open the SKP file and watch how the scene visibility changes as you step from one of the other scenes to the scene called End boards 2D.

It sounds like you’re doing things in reverse order. Set the camera position and the visible layers before you create the scene. If you make changes to the visible layers or the camera position after you’ve created the scene, you’ll need to update the scene. Easiest is to right click on the scene tab and choose Update.

What’s your availability tomorrow? Perhaps I could set up a live demo for you and show you this stuff so we can talk about it and you can see the process in action.

Thanks, I’ve got it now, all set. Thanks again for your help.

Thanks, that’s a clear explanation.