Creating scenes and layers for alternate furniture/fixture layout

I am using SKetchUp Pro 2019 still on the trial version. I am trying to create alternate scenes for a 2D floor/fixtures plan in the same file. I copy and moved all the fixtures and assigned them to a new layer. When I make the initial furniture layer not visible it takes out parts of the new layer also. This happened before. I wonder if it is the trial version as someone else looked at it on their computer and did not have that problem.
Went to this

.
A little frustrating.

Without seeing your model we can only guess. By posting your model we can give definitive answers.
My guess is you are using layers incorrectly, assigning layers to raw geometry and expecting that to separate geometry.
Read up on layers here. https://help.sketchup.com/en/sketchup/controlling-visibility-layers

This could be for many reasons. One idea is the the edges were drawn on the first layer–even though you assigned the groups to the second layer. Read up on layers. Keep Layer0 active. Draw and keep edges on Layer0. Only assign groups and components (and text & dimensions) to other layers to hide them.
The bug was when they came up with this idea. Everyone must learn the logic jam. Once you do then these situations become easier.

Also, one easy way to end up with raw geometry and on something other than Layer0 is imported dwg files. Don’t know if that was involved in this situation.

1 Like

It appears to me you have drawn the different components of a model in different layers.

Thanks, I think I did draw them on the right layer, but will definitely read up on layers.

Thanks for your input, much appreciated. I will read the info you sent.

No imported files, but thanks so much for responding.

We are just guessing at the typical issues, without the file to check.

I do this kind of thing all the time. You only need one layer for each type of object first.
For example:
OBI-PLUMBING
OBI-WINDOW
OBE- WALL

Place all objects as groups or components on their respective layers.

You will then need three additional layers and groups.
BASE GROUP on BASE GROUP LAYER…Contains all common objects.
OPTION 1 GROUP on OPTION 1 GROUP LAYER…Contains only Option 1 Objects.
OPTION 2 GROUP on OPTION 2 GROUP LAYER…Contains only Option 2 Objects.

Create 2 scenes.
OPTION 1…All layers on except OPTION 2 GROUP LAYER.
OPTION 2…All layers on except OPTION 1 GROUP LAYER.

The visibility of the individual objects will be subordinate to the viability of the parent group layer.

No. The code of the trial version is identical to the licensed version with the sole change of refusing to run at all after the trial period unless a license is added. Without seeing the model I can’t guess why anyone else’s computer would show the content differently.

One possibility is that you are making a layer “active” before drawing the edges and faces that you subsequently make into a group or component. This is not necessary or correct. Always leave Layer0 active and only assign a layer to a finished group or component.

Another possibility is if you have exploded a group or component that was associated with a layer. SketchUp will cause edges and faces that were associated with Layer0 to change to the group/component’s layer when exploded.