Need help understanding rotate

Morning! I’m messing about, trying to teach myself the rotate tool better by folding paper airplanes.

I’m on iPad, so native toolset only.

I managed to finish the model, however… I cheated once. I couldn’t figure out how to fold the group in the image below. Am I correct in the assumption that I cannot rotate an arbitrary line that is off the given axes? I assume that I need to change the group’s specific axes, but am having trouble finding that option. Is there a trick to using inferences or something so that I don’t have to edit group axes?

Here’s the file
Airplanes for Rotate practice.skp (101.4 KB)

I separated a copy of the group higher up the green axis, and then copied that again to show the group within a group structure that I thought would allow me to rotate the fold I wanted.

Click - Slide - Rotate


Since @Danimaupin is on ipad i felt I should point out that you CAN click and drag to set rotate direction as @mihai.s showed, but it is easiest to do so using Click-Move-Click mode

For me, in click move click or just draw mode, I can’t set the rotation direction as shown in the screen recording. The cursor suggests the recording was done on desktop, which does allow setting of the direction.

The rotate, arc, and pie tools, all allow setting of the plane during the first click and drag. On iPad all three tools seem to set the plane on the first click, and you can’t change it after that.

It was finicky for me, as well

I double clicked to select geometry.
I clicked the Rotate command.
I clicked and tried to drag to set the rotation center, but it stayed locked to the blue axis.
I rotated the selection on the blue.
I did an Undo.

Then I could click and drag as expected.

I tried, and still no go.

You guys are all way ahead of me, I can’t get the rotate icon to stand upright in the middle like that… I’m trying click move click, but I am missing something.

I’m on a laptop and use the page up, left and right arrows on my keypad. Do you have something like arrow keys?

I sometimes get it to work with click-move-click. Feels fussy, though. Does the camera POV have an influence on SU’s presumptions of orientation to start?

“Well, sometimes the magic works. Sometimes, it doesn’t.” - Old Lodge Skins, “Little Big Man”

1 Like

I hadn’t thought about that! I’ll try.

Have to agree with RTCool. Rotate has always seemed fussy on both my iMac and MacBook. Definitely seems as if my point of view has an affect on lining things up the way I want…. have just gotten used to having to fiddle about at times.

I just can’t get it. I’m sure it’s user error.

With click-move-click you have to long/strong press so a circle pops under your pencil. That’s when Sketchup acknowledges a particular step of the tool. (I’m assuming you know click-move-click is a drawing mode you can setup on settings).


  • pre select face
  • drag pencil to the center point of rotation along the edge and press stronger until the circle pops;
  • drag the pencil along edge to use as axis and release. The protractor will align perpendicular to edge and become black in this case (maybe it should become pink)
  • now drag the pencil to a point on the face you want to use as reference for rotation and press stronger. Circle pops.
  • drag pencil around and you’ll see the face rotating. You can release for navigating your model.
  • when you find the destination point just strong press again.

I find it very unfortunate that I can’t use just draw mode on this scenario.

I also dislike that hitting the green, red, perpendicular or parallel inferences prior to rotation has no effect.

1 Like

Ok, you have to forgive me for the clunkyness of this, haven’t use a mac product since some time in the early 90s, so just working out how to use an ipad is bad enough, and working the controls of the ipad ap and a screen recorder…

Hope this works, I was able to use the rotate align drag method with the Click-move-click setting, would very much prefer if it work with the Just draw method.


I still cannot get it to work, with pencil, trackpad, or mouse.

Curious about how you screen recorded. That’s a built in feature on iPhone and iPad, and isn’t difficult to use.

OK… here’s a little video that hopefully helps clarify what’s what.


Only one time did my trackpad do the right thing, and would not do so next time I tried. Pencil hasn’t yet worked.

I thought I had audio recording, but it seems not. The first action is my click-drag with trackpad, and the result is that the protractor moves to the new cursor location.

Second action is pencil, with click/hard-press-drag-release. The protractor stays locked to the blue axis.

You’re looking rather down on it, right? I’m wondering if you change your view to more of a 3 point perspective, it might “get” the third dimension better?

@colin what you’ve offered there in the recording is indicative of your not keeping the trackpad depressed, nor are you keeping the pressure applied to the pencil, throughout the entirety of the initial darg operation. That’s the key.

How do you do it with just your finger? (No pencil, no trackpad, no mouse, no keyboard)