Need Help! File corrupted and can't open

Before we go down the wrong road. This file is fairly new, less than 4 hours of work in. For reasons I can’t understand, there is no autosave file. There is no backup file that doesn’t mean 3+ hours of work loss. The file won’t open. I have tried multiple computers. I have tried the new version of SketchUp. I have tried to import into a fresh file. I have tried any and all setting for the graphic card.

What appears to have happened is that SketchUp failed to enact ALL safety measures and corrupted the file during a save/autosave.

If anyone can help, that would be greatly appreciated.CURRAN PARK MODEL.skp (4.2 MB)

Generally speaking only trimble employees have access to a few tools that can occasionally retrieve something, @colin will probably come along soon and see what he can do.
In the mean time, the most common cause of a corrupt save/autosave file is running your files from a network location rather than a local drive. Even a synced dropbox can cause issues. Basically if the save kicks in at the same time as a sync or when there is a bottleneck in the network or any other type of clash, you can end up with an unusable file.
Best always to work locally and sync manually.
If this isn’t the case for your issue it’s good to know anyway.

That makes sense… sort of. I have been working from network locations (with SketchUp) for 15+ years and not once have I run into this issue. If Trimble’s programmers can’t fix this, that is concerning, especially if, as you say, this is a known issue.

The problem with the approach you are presenting, in most corporations, this would mean that the file resides outside of the backup system. Individual workstations aren’t backed up while file servers are.

How could you tell there was no autosave file?

Not trying to be snarky here, but I looked. Nothing. I looked in the folder where the file was saved, nothing. I looked in the AppData>Local…>RecoveredFiles folder, nothing. I did a search on the drive, nothing. I guess I would ask, why are you asking that? It was mentioned by Box that there was a chance you could use trimble proprietary software to check/fix this. Is that possible? Is there something else I should be looking for?

It’s unusual to have a RecoveredFiles folder at all, if it doesn’t have any files in it. But, assuming you went here:

%LocalAppData%\SketchUp\SketchUp 2019\SketchUp\working\SKETCHUP\RecoveredFiles

and it was empty, then that’s the end of that idea.

There are internal debug tools I can use to try to get something out of the file. If you want to put it online somewhere and send a link, I will give it a try.

Nevermind. Since I already uploaded the file in my OP, what would be the point? My RecoveredFiles isn’t empty, it just doesn’t have the file that I am looking for. There is a reason I rarely come to forums with problems. People don’t pay attention. People want to be a savior rather than addressing the problem at hand.

In the time it took for me to get nowhere on this forum, I was able to remodel the entire project.

Let’s call this resolved.

Sorry for not noticing your file in the original message.

I did try it, and it gives an error that I’ve never seen before. I will create a bug report for it. It won’t help you, especially as you have recreated the model, but seeing how it is corrupted might help someone else in the future.

By all means. If you can figure out what went wrong, that could be helpful for me and other sin the future. As I mentioned, previously, 15 years of professional use of SketchUp on a daily basis and this has never happened to me. I have had files get corrupted but never to the point that the AutoSave file isn’t created on the .skb isn’t produced at each save point. Luckily, modeling something the second time never takes as long as the first.