Need help editing components


I recently started using SketchUp to try and visualize/measure a microscopy/microphotography setup that I’m building.

I ran in to an issue today. I’ve imported two 500mm xt95 rails made by thorlabs from the 3d Warehouse. I’ve positioned them appropriately in my setup. Unfortunately I need a 750mm rail as well. I checked, there isn’t one in the warehouse. I then tried using the push/pull tool. I managed to get it to work by clicking “edit component.” Initially it wouldn’t work at all, when clicking on the part I wanted to change I just got a small red “O” with a line that goes diagonally though it. Editing the component fixed this. (Went back and found that it wouldn’t let me edit smoothed surfaces). Fine, I managed to pull the 500mm component to the required 750mm. Then I couldn’t exit. I was stuck trying to edit this one component. Everything had gone gray, and no other tools would work. (except for eraser, managed to erase something with it).

I tried to be clear, but if anything wasn’t, please let me know.

I thank you in advance for your help.

I had to search the 3D Warehouse. I found two different rails with a search for thorlabs xt95. Both are 500mm rails and both can be modified in length with Push/Pull on their ends.Maybe there’s another rail I didn’t find. Perhaps you could upload the SKP file with the problem rail.

Typically when you run into something like this the cause is that there’s more than one face. If the surface has been subdivided and the shared edges softened or hidden, it’ll look like one face but really be more than one. You can easily identify that by turning on hidden geometry (View menu).

Another possible reason comes in the case of nested components and not drilling down to the actual face.

You are right, sorry, I was using the one that is multi-sided, like a column. You were able to push/pull it without having to select “edit component?”

How does one exit out of that once done?

I will try your solution.

No. To modify (edit) it you must open the component for editing. Then Push/Pull works fine. You can either choose Edit Component or I prefer to simply double click on the component with Select.

I didn’t see anything additional once I turned on hidden geometry. Here is a screenshot of what it looks like with hidden geometry turned on:

Oh, I understand. Once you’re done editing the component, how to you exit out so you can then view/move and just generally work with other parts?

Either click in space or on something else with Select, right click and choose Close component, or hit Esc.

I tried it, but it didn’t work. Everything is still grey.

Tried what?

Zoom back so you can see some empty space and click in it with the Select tool. Otherwise, upload the model so I can see it and help you out more easily.

In order: Click in space with Select, right click to close, and Esc.

It worked! Thanks a bunch!

What worked?

Right clicking and selecting “close component.” I hadn’t seen that before. Thanks a bunch man, that was a huge help.

Glad to help.

When Dave wrote about clicking to close the edit mode, that’s click outside of the component/group bounding box.

1 Like

Here’s an easy way to learn how things work…
SketchUp Video Tutorials — SketchUp YouTube