Nearmap Imagery Going Backwards in Time?

I was asked to add some additional imagery to a site model for which we had already imported the hi-res immediate site, and the available Nearmap imagery has now gone backwards in time from the images we had already imported (our current imagery shows a completed building and site, and the new imagery I’m trying to import has the same building under construction).

I would hope that Nearmap has the latest and greatest, and I don’t understand why it would go backwards in time from imagery that it already has. Anything I can do to work around this?

What’s the location?

Are you still using SketchUp 2018?

I’m using SketchUp Pro 2022 (the imagery was originally purchased with 2021).

I’ve attached a screenshot of our existing model and the imagery that I’m currently getting when I try to geolocate.

7211 Britton Drive, Columbus, Georgia, USA


Hmmm… Looks like Google shows similar older imagery like Digital Globe shows.

Have you tried contacting the NearMap folks?

Maybe you could update your profile. It’s showing you’re still using SU2018.

I went ahead and purchased the imagery, and the more recent aerial imagery actually imported. So, just a matter of the preview and actual image not being the same.

Thanks for the help.

So the low res Digital Globe imagery shown in the Geo-Location window is older than the hi res NearMap imagery? Interesting. Could be a nice thing if they at matched at least regarding date.

Glad it worked out for you, though.