Native Bezier curve extension update refuses to install

Hi everyone, hoping for a little help here please with a stubborn issues that’s beginning to drive me nuts.

Recently Sketchup notified me that I had an update to the native Bezier curve tool available for installation in the extention manager but when I tried to install it I got the following error

At first this didn’t bother me too much as I rarely have need for this tool in my woodworking models but as the extention manager pops up everytime I start sketchup offering me this update I have found it to become increasingly annoying and on the odd occsion I’ve use the tool I’ve had some small issues with it like the screen icon still showing as the select tool icon, so I’ve spent some time trying to resolve the issue without success.

I’m not an expert of file permissions etc and despite some extensive googling of the issue I seem to be the only person suffering from it as I can’t find anyone else with this issues posting a solution on the web.

Any help anyone can offer would be greatly appreciated.

Oh, and happy New Year to you all as well.


1 Like

A permissions issue can often be traced to how you installed Sketchup. You should install it by selecting the installer .exe, right clicking and choosing Run as Administrator.
If you didn’t do that or don’t remember or even just because, you can do it now and choose Repair when given the option.
This is different to being an admin when you install. It won’t mess with extensions or toolbars, it will simply make sure the program is installed correctly with all permissions.
If you don’t have the install.exe you can download it from Here.

I’ve been seeing this, too. I reported it so hopefully it’ll get a fix. According to the Extension Warehouse it hasn’t actually had an update since 2013 although it may only be the description that hasn’t. I haven’t agonized over it much since I really don’t use it, favoring Fredo6’s FredoSpline and BezierSpline tools.

1 Like

Dave, have you installed Sketchup properly?


LOL! That made me blow coffee out my nose!




I’d just poured it, too!

Thanks Dave, At least it’s not just me then. I shall just have to temper my frustrations on this for now. Not sure why it’s begun to annoy me quite as much as it has so I’m going to put it down to Covid as that seems to be a catch all for all things these days :grinning_face_with_smiling_eyes:

Thanks Box, I’ll give that a go later as I have no idea how I installed it back in 2020. This old age short term memory thing is clearly getting worse :stuck_out_tongue:

If you haven’t already installed it you shouldn’t get a message about it. If you want to install it again, go to, search for it, and download it. Then in SketchUp go to the Extension Manager, click the Install Extension button at the bottom and install it. Ignore that it shows as unsigned.

Presumably you are using SU2021. Your profile says you are using SU2018. Please update.

If you are using the latest SU2021, Extension Manager is in the Extensions menu.

Hi Dave, I tried that but it still shows as an update available and the same error occurs when I try to update it. I’ll just have to wait for the devs to fix it I guess.

Sorry about the profile, updated the version now.

It will do but just ignore the message. Or uninstall the plugin and use one of Fredo6’s tools to draw Bezier curves instead. :wink:

I might be on a wrong track here, but if you initially had the extension in a folder other than the standard suggested by SU, is it possible that the user permissions set in the security for that folder are preventing you from running the Bezier update? As you are using W10 OS it is sometimes worth checking this, just in case W10 has set something you weren’t aware of or expecting.

Maybe but I didn’t put the extension in a non-standard location. It’s in the default user location.

Sorry Dave - I meant to address Keggy with my suggestion …:wink:

I recently had the same problem, that it kept saying there was an update, but I wasn’t able to update it, but redownloading it from the extension warehouse fixed it.

I responded since I had the same problem he had. Non-standard folder isn’t the problem.

I am having this issue as well, with the same tool. It first happened about a month ago. Uninstall is greyed out, so that is not an option. I went into windows file system to delete all traces of the extension (also under windows profile) and re-installed it via extension manager. However, today the same issue is back again. Somewhat annoying unfortunately. All other extensions update fine as always.

I expect they will get this fixed soon. In the meantime ignore the message that there’s an update available for it. The haven’t been any real changes made to the script since 2004.

1 Like

Thank you! I will stop looking for faults on my side and wait for updates. :sunglasses:

1 Like