My SketchUp turned all grey when I inserted a model

#help wanted
I was just about done with my patio project and tried to “plant some flowers” to get my wife more onboard with the idea. I chose a lavendula marked Geo Location (didn’t know what that meant really) and then the sketchup screen went all grey.

I 've tried restarting, opening in browser (I run Free in desktop version for Windows). Tried clicking basically everything in camera settings and zooming in and out and all that. Nothing works.

Any ideas that could help me out here?
Cheers!

could you share your file here ? either directly or using stuff like wetransfer ?

only by exploring it can we tell you exactly what the problem is…

House.skp (7.2 MB)

Dunno if this is the right format. I’m kinda new to sketchup so sorry for any hickups)
Thanks!

so I managed to make it work,

kinda


first of all, congratulation on having a purged file, it’s not often we see that.
On my screen it was all grey as well.

First thing I did a “select all” manœuvre (ctrl-a)
then I opened a new file and paste it there.
and your project appears, or at least all the non buggy things.

I noticed an element didn’t follow in the outliner (it’s a go/pro thing), so I re did the copy a different way and it turns out your kitchen island was causing the bug. see how I can’t unselect it ?

However, since then, whenever I save, there are errors being solved, again, and again the same.

Thing is I can’t tell you where these faces are, why their orientation is incorrect, and why sketchup keeps flipping them again and again upon saving…

Here is your file - minus the buggy island

try it, I hope it won’t bug anymore despite the errors being corrected.

House 2.skp (5.1 MB)

1 Like

Omg you’re amazing! Thanks a million for fixing this! The island can be deleted, that’s no problem. The main thing here is the patio.

Btw. Did you also take the time to lay down the decking on the joists? :smiley: Can’t recall me doing that haha.

I made them reappear, they were hidden and didn’t come with the first copy (but I could see them in the outliner)

and when I imported them they were a bit misplaced to I slightly moved them :wink:

2 Likes

In addition to the model of that ‘island’, this component also contains texts located at a great distance from the origin. You can extract ‘Component#11’ (which is the island) from ‘component 1f2…’ and then delete that ‘component 1f2…’ (which contains texts far from origin).

Do not import objects from 3D Warehouse directly into your model.

House-3.skp (7.4 MB)

1 Like