My Sketchup Pro 2014 for Mac won't run unless I upgrade


#1

I tried to run my Sketchup Pro 2014. It pops up a window saying a newer version is available and has a button to click to download. But I can’t close the window and just continue running Sketchup 2014. Do I have to upgrade? what if I want to continue using my Sketchup 2014?

Thanks,
Brita van Rossum


#2

I’m having the same problem - so frustrating! Even more so as I had the same issue a couple months ago and got it resolved but can’t remember or find what I did to make it work. Pretty sure it was via tech support but it’s now the weekend and I can’t get anything done.
If you find a solution, please post as will I.


#3

I am also have the same problem… I even re-downloaded Sketchup Pro 2014 from the download page and it still tells me it’s expired. 2015 doesn’t work on my computer because it’s not compatible. I sent an email to support so I’ll post if I get a helpful response. Please let me know if you find a solution.


#4

I found this searching SketchUp help but it doesn’t seem to apply.
http://help.sketchup.com/en/article/39436

I’m in the same boat as I can’t run 2015. Also reinstalled SU2014 to no avail. I’m on a Mac and tried trashing preferences files as suggested elsewhere on this forum which also did not work.


#5

I am having the same problem running MAC OS X 7.5, so need Sketchup Pro 2014 but keep getting a message that my version has expired, reinstalling seems to have no affect.


#6

I’m trying to recall the posted solution, I think it was…

close SU…
disconnect from internet…
open SU…
reconnect to internet…
I think it resets something, but can’t remember what…
It was on this forum 16/17th March, but where is the search field???


#7

I disconnected from the internet and opened up my file - it works fine. I kept the file open and turned on the wifi and it worked fine still. So then I turned SketchUp back off, turned on the wifi, and opened the file again. It doesn’t work and the pop up window is back.

I suppose the temporary solution would be to disconnect from the internet and use it. Hopefully there is a more permanent solution though.


#8

Thank You! Yes that works for now - at least I can get some work done!


#9

yes i think there is one more step, but my memory is blank…
john


#10

Thank you! Let us know if you remember


#11

top-right


#12

@Jeff
cheers for that, but it cant find any posts containing the message 'Your current version has been expired’
I try other key words…
john


#13

heh, yeah.
I’m not having much luck with it either :confused:


#14

What about opening the Preferences dialog, going to the General tab, and unchecking the “Automatically check for updates” option ?

I always do this in all older SketchUp versions, after I install the newest major version. (I keep at least the last 3 versions installed for testing plugins.)


#15

Repeatedly Telling me to Update to a New Version


#16

I contacted SketchUp Tech Support over the weekend about this as I tried to fond work arounds. Their response on Monday blamed the problem on a Saturday SketchUp 2014 bug which they fixed. It now works OK for me.