My lines -even the axes- don't appear to be straight

all my line including the axes lines are weird… it looks like small pieces of lines connected together

Your display is probably set to 0x antialiasing. You can try a higher value that will “blur” the pixels more for a smoother look. Don’t overdo it, high values slow your display down. Window menu>Preferences>OpenGL.
image

1 Like

The stair-step or jagged appearance of diagonal lines on a raster (2D pixel) display is an aliasing (or “false appearance”) artifact of the discrete digital pixels which comprise the diagonal line. Commonly termed “jaggies” these are inherent in a raster display.


There have been vector displays (I used one in the 1970s, a variant of the GT40 below) which can draw exact lines from one point on the screen to another point. That really looks great, but a disadvantage of vector displays is that they cannot draw shaded (solid) areas very effectively.
2 Likes

thank you…It was 0X.
i just want to know what is the default? 4x?

I don’t think there is a default.

I did a test where I chose 8x, then deleted preferences, and reopened SketchUp. It was then on 4x, so I think that in most cases that would be the default.

What you actually need depends on your monitor type and size. For me, on a 16 inch Retina screen, I could be in 0x and never be worried by whether lines are jaggy or not. If I’m on 2x I have to magnify the screen to see any imperfections. I still often do leave it at the 4x default, as my machine is fast enough to cope with that.

For a larger monitor, especially a non-HiDPI screen (the Windows equivalent to a Mac Retina screen), you will notice a bigger change when you go from 0x to 4x. If that is still not smooth enough, and your GPU is powerful enough, you could go to 8x or 16x. Most modern screens are detailed enough not to have to go that far.