My component has cruft that wasn't there when I made it!

I’m using Sketchup Web.

I made a component which is nothing more than a notch cut into a piece. Basically, I made a rectangle and the push tool to do the normal thing. It is situated to the top of the notch is flush with the top of the piece it has been put into. Looks great. I made a component out of this. Then I used the component, and the top of the notch seemed to be a minute amount below the top surface - there’s a skin there now. I cannot select it.

Here’s an image of the used component on the left, and another on the right, made by hand, just like the original notch.

Can someone help this noob?

I use x-ray to see the inner component and select it

I could not select it even with the x-ray style turned on.

Attach your model so we can see the problem rather than guess.

Here we go. My component is “notch3”. You can see all the small notches - that is what the component was supposed to look like.

bench3.skp (721.0 KB)

Components can only cut one face, you appear to be trying to cut two faces.
The cutting plane of the component is on the large face, so the small face will retain it’s own face plus the face it is against, causing z-fighting.

1 Like

Using two components, one for the notch and a simple hole for the other face you can get to this, but the edge in the corner won’t get hidden. Cutting components only cut faces.
image

1 Like

Thanks all. I suppose that’s that.

Well it depends what it is you are wanting to achieve. Perhaps we can offer other options you haven’t thought of.
You can do a pretty quick array with raw geometry.
Array01

1 Like

Ah I didn’t try the eraser on that little piece. I tried selecting it to I could delete it the hard way :smiley:

Just to be clear, that isn’t your component in my gif, just the raw geometry.