Issues with components


#1

i am having following two issues with components in sketchup pro 2014

1- i created a rectangle on RED-GREEN axis and gave it properties “glue to any surface” and "cut through ", then saved it as a .skp file.
In another sketchup pro session i open a box which is also on the RED-GREEn axis and import this components it comes in perpendicular to the box and not parallel?

2- i do not see this component in the windows-components list ?

thanks


#2

You should right click on the component and choose “save as” instead of saving the file iself.


#3

A ‘gluing’ and ‘cutting-component’ must have its Blue axis perpendicular to the face onto which you expect it to ‘glue’ AND ‘cut’.
So it’s best to make such a component on a face before you save its geometry - because SketchUp assumes you want it to at least ‘glue’…
However you can fix this existing component…
Place an instance.
Select it.
Now us the context menu to Reset Axes…
Ensure the Blue faces out of the component in the direct that’d be perpendicular to the face you want it to ‘glue’ onto and to ‘cut’…
When you now insert a fresh instance of that component it should both ‘glue’ and ‘cut’ the face onto which it is placed…

Additional info:
The target face needs to be in the current context - it will still ‘glue’ but it won’t ‘cut’.
The cutting object must has at least one continuous loop of edges on the plane of the face that you want to glue it on to - otherwise it won’t know the ‘hole’ it needs to ‘cut’…


#4

ok I have tihs box and i can select the right surface and cut through it as you see in pic , so i know i have selected the right plane, but when i put the bazel its not putting it at exactly top but a little below , see picture 2 please.
also its not cutting through the surface .


#5

most likely the cutting plane and the insertion (axis) point don’t line up. could you post the model part (purged) in question so we can work it out?


#6

Is this still the same question as the first post?


#7

the first post i could not even cut the surface , this issue was placing the component on the surface and cutting through .
even though the component did not “snap” to the surface but i could still “move” it to the surface but zooming in and using the move tool place it right on the surface.
then for cutting through not working i enabled the xray mode and went under the surface and used push/pull tool to cut the bazel opening .
so I am ok for now.
thanks everyone for your help


#8

ah i am not getting it , this cutting through thing is not working , i am following step by step this youtube tutorial

but when i create my component and stick it on the surface it sticks but does’nt cut through . and i do select the surface before placing the component.
what am i doing wrong ?/

i want to be able to paste this window on on the surface and see the opening cut through, is it possible or am i misunderstanding this cut through function.?


#9

is the surface raw geometry? if not then click into the group or component then place the cutting component

is the cutting axis on top, running in the correct plane?

please post the model, so we can check it

the cutter only cuts one plane, to cut a plane behind you need a second cutter which can active after an explosion. there are a few work arounds

http://sketchucation.com/resources/tutorials/317-window-cut-oopening-on-face


#10

iam not sure what you mean by raw geometry … i made a rectangle and then used the push pull tool to make it 1.6mm thick.
i wil upload the window and the face plate both shortly


#11

testwin.skp (6.8 KB) controller3.skp (16.4 KB)


#12

raw geometry refers to ungroup geometry, this raw surface is what the component “cuts”, So as you have done the cutting components are within the controller3 component

In controller3
You will notice that there is flashing surfaces on two of the testwin ----called z fighting… this means they are slightly off line with the surface…deleted these two and replaced by dropping two from the component browser directly on the suface or copy the correct one


#13

so is it working for you ? or you say ing that i sent the wrong files?
i think i know what you mean. the shimmering window that you see half on board and half out is directly pulled from the windows-component


#14

i retried it … i draw the window exactly on the RED-GREEN lines . . but still the same … how can the part be “slighty off” as you said?


#15

sorry

the two on the right are correct but are placed on the group and not within it , because they are all within the controller3 component I made the wrong conclusion


#16

When an instance of a component which has ‘gluing’ behavior is placed in the model, it glues onto the selected face and it orients itself so that its blue axis matches the face’s ‘normal’.
A gluing component has its blue axis represented as a blue 2d-cross, rather than the usual blue axis line.
A gluing component will glue onto a face even if that face is not in the same context as the gluing-instance itself - e.g. the face is inside a group or another component instance.

A gluing component can also have ‘cutting’ behavior.
If the face onto which it is glued is in the same context as the instance itself, then it will ‘cut’ a hole in that face [visually at least].
However, if the face is within a group or another component instance there is no cutting - only gluing.

A cutting component will also fail to cut a hole if the geometry in the component does not form at least one continuous loop of edges on the face’s plane - i.e. the loop’s vertices must all be at the z=0 within the component’s definition.
If this is not the case editing the component can fix it, but then any instances which have already been placed and glued will still not cut - they need replacing with fresh copies, or a plugin which ‘reglues’ can be used [e.g. part of my HolePunchTool].

Your example SKP works fine - but only if you work within the group edit context, and place the instance directly onto the face - otherwise when placed onto the ‘container’ you’ll only get gluing - with no cutting.
If you delete the back face of the box within the group you can see that the component does indeed cut the hole.

Incidentally the face in your frame is facing downwards so you see the back [reverse it so visible faces are the ‘front’].
This obfuscates the issue as it looks like the ‘glass’ hole in the frame is not cutting a hole as you see the inside of the box’s back-face and it’s the same color as the incorrectly oriented frame’s face.

A cutting component only cuts one face - the face on which the instance is glued.
If you want a cutting instance to punch a real hole through multi-skinned geometry [i.e. two or more parallel faces] - like a wall - then you’ll need a Plugin…
Look at my http://sketchucation.com/pluginstore?pln=HolePunchTool
This allows you to punch a real 3d hole, with matching reveals, which selects and moves etc with the instance.
It also has extra tools to reglue instances etc…

Good luck :wink:


#20

ok i am getting somewhere ., if i create a face plate in the same session then select the component from the window-component menu option it gets glued n cuts through as you see in picture. but what iam not understanding is why is he making two face plates? i only create one rectangle on the ground plane he creates a rectangle on the RED - BLUE plane where also i can glue the object.

so two questions:
1- how can i fix this so that it only creates one rectangle?
2- how can i open a new session and create the face plate there and be able to select this bazel component?

thanks


#21

ok i my hole punch is working now but i have one more issue, see its creating a depression in the bottom surface (rightly so cause its p;unching the whole surface area of the component through, i just want the bazel window to be cut through.
can i fill the bottom surface somehow after cutting through?


#22

You should be able to select that surface and pushpull it out to match the rest of the bottom, then delete the edges that are no longer needed. This may once again entail opening the necessary context for edit!


#23

Without any examples of the supposed cutting components this is a guess…
Your cutting component must be set to be ‘gluing’.
Its z/blue axis must match the normal of the face onto which each instance will be inserted.
The cutting ‘loop[s]’ must be located at z=0 in the definition’s definition.
If the component’s loops are misplaced then weird results will happen in normal cutting, let alone any related ‘punching’…

If you posted the component then we might fix it…