Cutting components leave holes after their layers are made invisible

bug
layers
components

#1

This bug has actually been around for at least 4 years. I reported it in the sketchucation forums in early 2015: it was duplicated but then no further interest: I guess this is a more appropriate forum, so I’m reproducing it below:

I’ve actually noticed this bug for several years: if I create a surface inside a group, then cut a hole in that surface (inside the group) with a (cutting) component, and then put that component onto its own layer, and then finally turn off that layer, the component will disappear, but the hole that it cuts in the surface will remain. To get rid of the hole I have to select the surface inside the group. It’s quite annoying, as I like to use component (on their own layers) to model potential locations for doors and windows, and use layers (via scenes) to switch between them. But as soon as I put the surface inside groups I get these annoying ghost holes left behind by each component that is no longer visible because its layer has been turned off.

Steps to reproduce:

  1. create a surface
  2. create a group containing that surface
  3. click into that group
  4. cut a hole in the surface with a component
  5. assign the component to a new layer
  6. leave the group
  7. turn off the component’s layer
  8. observe an annoying hole where the component used to be.
  9. click into the group again
  10. observe that the hole has disappeared.

Note: this only happens when the surface being cut is within a group (or component) of its own.

This was the original thread:

http://sketchucation.com/forums/viewtopic.php?f=11&t=61321


#2

Can you share a SketchUp file that shows this?


#3

test-component-layer-bug.skp (103.9 KB)

make the ‘test’ layer invisible and you will see that although the component disappears it leaves behind its cut opening.


#4

Hmmmm…


#5

Crazy! This is what I see (fresh install of Sketchup 2016, but also on every version of sketchup I’ve installed since about version 7).

Could it be mac specific?


#6

No I wouldn’t say it is Mac specific because I get the hole on PC.
As you see here, it is a hole until you edit the group, when it skins over and then cuts again when you edit again.
And the layering appears correct.


Creating detailed wood textures with graphics
#7

Ah, so you are seeing the same thing I do: that is, when you make the component invisible, the hole that it cuts remains (until you open the group containing it). And the converse behaviour as well. It’s very painful when I’ve got lots of cutting components, buried in lots of different groups on different layers, and I’m using lots of different scenes to control the visibility of the components via their layers. So when I switch from scene X to scene Y, I have to spend minutes clicking into all the affected groups in order to make the various holes appear and disappear (ie. fix the model) each time.

This definitely did not happen in older versions of sketchup: I think it started happening sometime during sketchup 7, or perhaps in the initial release of sketchup 8.

That is to say: I appreciate that the layer/component/hole behaviour can always be made consistent by manually clicking into all the affected groups: but to me it seems to be a bug that I have to take that manual action, whenever I hide or reveal a cutting component inside a group: ie. that the model is not automatically correct as soon as I’ve changed the layer’s visibility state, and I have to go around fixing it each time. Especially since it used to work perfectly in earlier versions of sketchup.


#8

I would agree that it should be called a bug, especially if it doesn’t happen on Dave’s machine, therefore showing that neither version is expected behaviour.


#9

Oh I’m so sorry: I didn’t notice that you weren’t Dave! Thanks very much for wading in and confirming the bug!!

Do either of you happen to know how to bring this to the attention of the Sketchup devs?


#10

I would also agree that this behaviour is buggy.
I noticed that I’m having problems putting a new (fresh) test component flat on a new face. As if your component isn’t a ‘Glue to’ component, although I can clearly see it is.

I made my own simple window component (assigned to ‘test’ layer) and had the same cutting problems as you have, as soon as the cutted face is (at least) one context deep.

To me it seems that SketchUp is only testing the actual state of cutting components in current environment. It should loop through the entire model, i.e. all (nested) levels whenever a some layer state is changed. To then display the correct rendering.

p.s. Actually there appears to be an (incorrect) invisible face, not a hole. For you can still get the inference ‘On Face’.
Once the cutting is restored, there is a hole where you can reach behind the cutted face.

p.s. Also, whenever the test layer is ON again but cutiing doesn’t seem to be restored yet, you can already reach behind the cutted face to other geometry.

It seems that only the render isn’t done correctly. The geometry itself cuts properly, following the layers.


#11

Some say it’s suspicious that we have never been seen together.


#12

I tried it again this morning and now I’m seeing the same thing.


#13

Kind of like Clark Kent and Superman or Bruce Wayne and Batman. :smiley:


#14

That begs the question: which of you is the alter ego?!

Is there a process to get a bug report like this onto the Sketchup dev team’s radar?


#15

No one has ever described me as mild mannered.

I started a thread in the back room to bring it to their attention. So we shall see.


#16

Thanks! It would be great if they used a public JIRA or some such system!


#17

There is support for pro users including direct access but for Make users, this forum is probably the best thing. It gets many more eyes on a problem and there are a number of folks from the SketchUp team who keep on eye on it.


#18

You can use the @relevant team member to get someones attention, but as i wasn’t sure who was responsible for this specific possible bug, i used this opportunity to ask them to give us a way of knowing who to ping on such questions. I’m sure we’ll get there.
Sorry I didn’t mention it here so you knew something was being done, just a bit busy myself.


#19

Many thanks! Fingers crossed! :slight_smile:


#20

Hi all-

We have this issue in our bug tracking system - looks like it’s been around for a while. I did a +1 on that issue with a link to this forum post. #25260

Thanks,
Marc