Can't cut surface

I don’t really know sketch up that well and I’m sorry if this is a stupid question but I am very annoyed and I have tried a lot of things but my surface won’t make the cuts I want for my windows :frowning: i googled it and all… would someone be kind enough to check my file please??

sorry but I can’t really post the file!!! please give me an e-mail if you want to help :smiley:

You’ll need to drag and drop your SKP file into the initial post. (Use pencil icon to edit previous postings.)

We could guess that your wall surface (faces) are inside a group or component. You need to double-click groups or components in order to enter into their editing context. (When this happens you’ll see a dotted box around the editing context that you are within.)

Cutting components must be inserted directly onto a face within that face’s geometric context. If you insert the cutting window component outside onto the group, it will not cut an opening.

Lastly, the window component’s definition must be set to “Cuts Opening” and be drawn in the proper orientation, in order to cut openings.

Please read the User Guide and bookmark it …

You may be also able to use the SketchUp Campus (if you have a subscription license) …

… Also, the old YouTube videos are still available …

(my file won’t upload I don’t know why I’m sorry)
yes my faces are in a group but I am definitely inside the group when I’m trying and I am not working with components for the windows just a group with the walls and i draw the cuts and use push/pull to make the opening. I also tried changing the axes to make sure I’m drawing parallel to the faces but still it creates an extra surface instead of cutting the existing one, like I’m not drawing exactly on the surface but I don’t know how can that happen?!

It might be too big ?
Try using Model Info > Statistics > Purge Unused…
If you have added lots of complex objects from EWH these will bloat the model - even if you have not actually placed instances of them.
The save the model and drag/drop its updated SKP onto your open post to upload it…
Failing that, try converting the part of the model where you are having issues, into a Component - then Select it and use the right-click > context-menu > Save as… to save it as a smaller external SKP file that can be uploaded OK…

Other thoughts…
Are you drawing directly onto a single face ?
If is a surface made up of several facets with smoothed edges between them you could have problems.
To see that View > Hidden Geometry > ON to show those smoothed [or hidden] edges as dashed lines…
You don’t need to change the axes - the inferencing tips will ensure you draw a rectangle flat onto a single face.


problem.skp (163.3 KB)
oooh ok thank you the component did it ! so as you can see if you open it, I can cut all the openings on the one facade and the other one is problematic (i’m only concerned about the two facades you can see when you open the file) please let me know what you think <3 it is very simple geometry without several facets or smoothed edges so I’m confused

The rectangle does not lie on the face. It’s very slightly out of plane. The top corner nearest the wall is 0.65mm away from the face of the wall, too.

It appears you are modeling the building upside down. Is this intentional?

1 Like

Your SKP shows two issues.

  1. The face of the lower part’s wall is NOT flat.
    View > Hidden Geometry > ON shows many Hidden lines splitting it into facets.
    Therefore you can’t draw a rectangle on it that straddles such a line and expect it to cut properly: at that point PushPull won’t work.
    Somehow you have skewed the wall’s surface and split it into facets - hiding or smoothing those edges won’t help.
    Some of those edges are ‘coplanar’ and can be deleted without destroying their related facets, which will then merge into one.
    Redrawing the wall and its punched openings is the only way to fix it properly…

  2. You have modeled everything ‘upside-down’.
    The Z/blue axis should be ‘UP’, and currently it’s down.
    I thought that perhaps you’d reset the axes, but no…
    I suggest you ensure all objects are unhidden and their layers visible them you rotate everything up the right way…

And a third issue:
As @DaveR points out the end wall’s rectangle is not drawn on the wall face so it doesn’t cut it.
AND if you draw another rectangle that IS on the face, then it won’t PushPull through the wall properly - because the outside and inside faces of the wall are skewed [not parallel].


oh my god I had no idea , it is very easy for so many things to go wrong without you even realizing it when you’re not a pro on sketch up hehe ! thank you friends, I guess I will just re draw my walls because this seems too complicated for me to resolve otherwise !! thank you for your help !:slight_smile:

Sometimes the best thing is to know when it’s time to cut your losses and start over. While this model could be fixed, I think you are wise to start from scratch.

Model it right side up and keep the axes aligned.

1 Like

Since you’re new at using SketchUp, you might want to start with a simpler building so you get the hang of it.

I have no choice unfortunately because this is about a uni project and even though I don’t know sketchup very well, I have the most 3d knowledge in my group… hah , we just have to work around it and save everything in photoshop because our deadline is in 4 days :sunny:

Good luck.

1 Like