MSPhysics - Disappearing Act

Wasn’t sure if this should be in Extensions or SketchUp, so…

MSPhysics. This is so wrong on so many levels! I needed to run across this extension like I need a hole in the head. I was sat for almost three hours this afternoon playing like a kid in a toy store for the first time. Okay, okay. So it doesn’t take much to keep me entertained… :laughing:

Aaaaaaanywho… After an animation plays for a bit, it will “dissolve,” for lack of a better way to describe it. Is there something wrong, or is this normal. Can’t say it’s so much a problem…I’m more curious than anything since at the moment I’m not sure how I would apply MSP in a model.

What IS annoying, however, is that after the animation was exported, SU crashed or just closed. Didn’t splat - just closed. When I tried to relaunch it, I got an error message that MSPhysics couldn’t load. I found that SketchUp was apparently still running under the “Details” tab of the Task Manager - I had to end the process. This happened again after exporting another animation… Any ideas?


The dissolving is actually clipping which is being caused by the objects dropping.
They continue to move away if there is nothing to stop them. Best to place a ‘Floor’ to stop them going off into infinity.

No idea about the other issue.


I used MSPhysics for a project about three years ago, and I found that the extension caused SketchUp to crash or terminate every now and then. Quite repeatably in some scenarios, rarely in others. I think that much of the extension’s logic is provided by so-called compiled code (as opposed to Ruby, which is interpreted code). If that type of code does something that is not valid, it will terminate SketchUp.

1 Like

how small are those objects and how far away from the model origin? Do they have the right bounding box and MSPhysics shape?

Maybe @Anton_S have additional ideas?

1 Like

Yup. I placed a “floor” like you suggested, and as long as nothing got flung far enough to fall off the edge, there was no “clipping.” But at least now I know what caused that.


Okie-dokie… annoying it may be on occasion, but I believe I can learn to compensate (save, save, save - OFTEN!).


I’ve since deleted that file, but the bottom of the “pan” was about 16" or 18" in diameter with the sides flared out to perhaps 18" or 20" in diameter. The shapes were all between 3" and 5" diameter. The whole group of objects was off the origin perhaps a couple feet.

As for the right bounding boxes, I’m assuming you are referring to settings in the UI. The first YouTube tut vid I ran across walked the viewer thru, I guess the basics. Everything was done thru right-clikking>>MSPhysics>>State>>Static (or Ignore or Frozen, for example) Later, in another tut, I began finding out about what you refer to.

<<< waits patiently for @Anton_S >>>
Thanks Cotty

It would make more sense to comment in his actual MSPhysics thread at Sketchucation.

That thread is 30 pages… and from what little I looked at, discussion is way over my head. I believe I can live with the extension the way it is based on the responses I got here.

TBH, the biggest thing I don’t like is not being able to have more than one instance of SU open at a time (the same error as when SU shuts down is presented). That might have something to do with the SU version…dunno. But considering I don’t know that I would really use MSP in any of my models, the issues are minor and I was mostly curious. There may even come a point where I will uninstall the extension so that I can go back to having more than one instance of SU open at any given time as I am used to doing.

I am tagging this as solved…but because I can only choose one solution… I would like that say that the responses from both @Box and @TDahl “solved” my curiosity. Thanks to you both, and thanks to you also, @Cotty for taking the time to add to this discussion.

My point about where to post it was more about where you were more likely to get a response from Anton. He was last on this forum in early june but on sketchucation within the last hour.

1 Like