Move a point a set distance?

How do you move a point in LO a set distance? When I grab and move a point with the cursor, for example: a point in a square, Layout will show me how far I have moved at the bottom right of the window, similar to the way SU does. I cannot figure out how to manually enter the distance I want the point to move.

Hi Adam,

To do this in LayOut, grab your entity and move it in the direction you want it to go. Drop it, then type in the distance you want to move it in the x and y directions. For example, you can type 1.5, 1.0 to move the entity right 1.5 inches and down 1.0 inches. Note that the units will be based on the paper’s unit setting, so if your paper is using mm, 1.5, 1.0 will be 1.5mm and 1.0mm.

Hope this helps,
Also Adam

Thanks for the reply, Adam.

In SK I can click, move in a direction, release, type the distance, hit enter to close the function – as you described. I thought the same would happen in LO. But it’s not.

In LO, what’s happening is that I click, move in a direction, and then release closes the function rather than allowing text input.

Perhaps there is a setting that I have accidentally changed to cause this.

That’s not what I’m seeing in LO2020.2. I click and hold to grab the entity to be moved, move it in the desired direction, let go of the mouse and type the desired distance.

I figured it would behave the way SK does, and it sounds, based on what you – @Adam, @DaveR – both have said, should work. But it does not work for me in LO.

I’ve noticed another issue – If I click on the measurement input window LO stops responding to my keyboard. Closing and reopening the file fixes this problem.

It sounds like you might be using comma as a decimal delimiter instead of period. In that case, I believe you would then instead type something like 1,5; 1,0 then hit enter. You shouldn’t be clicking into the measurements box before you type your values.

Adam

Ok, so I’ve reinstalled Sketchup/Layout 2020.2. The same two problems reoccur.

  • typing values for precise manipulation of objects/points doesn’t work

  • if I click anywhere on the bottom bar of LayOut window I loose ability to use keyboard shortcuts.

I am unable to input anything. That’s why I tried clicking the input window in the first place which has repeatedly caused all keyboard shortcuts to quick functioning, forcing a restart.

Drawing a new line, set the first point, move cursor in the direction I want line to go, type line-length works just fine.

I’ve tried changing my mouse, but that hasn’t solved the problem.

…but moving an existing entity does not work using that same technique?

Exactly.

I’ve tried recording what happens to the best of my ability. The end of the video shows what happens when I click the input window.

Don’t do that. Just type the numbers.

1 Like

I understand that I shouldn’t be clicking the window to input exact dimensions. If I do click the window, why do I loose the ability to use keyboard shortcuts until I close the file and reopen? You can see how the line tool doesn’t respond properly at the end of my video after I click the input window. I also hit delete after selecting the object and nothing happened.

I redid the video with audio and I describie everything I do.

Hey Adam,

That is an interesting problem you showed with regards to clicking in the measurements box causing all kinds of problems. I’ll have to look into that.

However, your problem with moving is that you aren’t doing it quite correctly. You tried two things

  1. Clicking on the entity and then attempting to enter a value.
  2. Clicking and moving an entity but not releasing it and attempting to enter a value.

What you need to do is click on and move an entity, then release it. After that, you can enter a value. Have a try at that and see if that works for you.

Thanks,
Adam

2 Likes

When you click on the bar/ dimension window you are deselecting your item.

Thanks everyone. @daveR called it – I just didn’t grasp that I had to type a value after placing object. I was blinded by the alternative method used in sketchup where a value is entered before placing the object.

FWIW, in both SketchUp and LayOut you have to start moving the entity (or copy of an entity) in some direction before you can type in the distance. Both programs need to know in which direction the move is to be.

Glad you’ve got it sorted out.

1 Like

I’m just not getting this. I just want to move some text say 6mm down. If I follow these instructions I have to move it first then type the dimensions which means it will be out of position from the original position by the amount dragged then the typed in value.
I just want to move my object a set amount whether its sdieways or up or down.

I’m not sure what’s so difficult about it. Start moving the text box in the direction you want it to go. Let go of the mouse, type the distance and press Enter.

When you type in a distance it replaces whatever dragging you did, it is not added to it. The dragging just gives SketchUp a direction vector to apply the movement to.

1 Like

Thanks Dave for very prompt response. Maybe I was tired last night but I just could not get it to work.
Got up this morning with a fresh head and works no problem. Thankyou for your help, much appreciated.

Kind Regards

Granite