Mouse wheel not orbiting after 2022 update?

I’ve got a Mac (Monetary) and using a Logi MX Master mouse. Just updated to SketchUp 2022, and my mouse wheel no longer orbits by default. I used to orbit around the model by pressing the mouse wheel continuously. That went away in 2022. Obviously, I can set the mouse wheel to orbit in my mouse settings, but that just triggers the orbit tool–I still need to click the left mouse button to orbit around the model. This is a real pain when repeatedly toggling between pan and orbit (which I do all the time).

Thoughts? Suggestions? Anyone else having this problem? Thanks in advance.

Strange. My MX Master 3 is working fine in Monterey. Check the settings in LogiOptions and see what the scroll wheel press is set to send. It should be sending a middle mouse button down event for SketchUp to interpret it correctly.

That did it. I didn’t realize scroll wheel press was different from scroll wheel click in Logi Options. Thanks so much!