Mouse acting weird in SU 2015


#1

The mouse in SU 2015 must be clicked twice to select something. Example: Open a new blank page and click one time on the image of the man standing. Nothing happens. Click again and he is selected. Then click onece in an empty area and nothing happens. Click again and the man is de-selected.

Second example: Open a new page in SU 2015. Click once on the man. Nothing happens. Move the mouse to an empty space and click again, The man is selected!

Is there something that can be changed to fix this?


#2

Are you sure it is actually two clicks? Much more often than misbehaving mice are misbehaving graphic drivers:
The 3d viewport lags one frame behind, so the result of doing something becomes only visible when the view changed another time. For example you click once to select an entity, but it still looks unselected. You click it again and it looks selected, but is now unselected (see selected entities in the Entity Info dialog).

Did you check that your graphics driver is up to date? Is there an update from the graphics card manufacturer?
For the mouse: Are you using the generic operating system provided driver or a custom one (with name of the manufacturing company)? If there are special mouse features enabled, try what happens when disabling them.


#3

I really don’t believe it’s actually the mouse because it works just fine in every other program. In fact, I installed SU 2014 on another computer and that one works fine with any mouse I use. So it’s got something to do with this particular computer.

I gavent thoought about the graphics driver so I will check that out. Thanks for the suggestion on that.

BTW, I did do a complete uninstall and install with no change. Both computers are running Win 7


#4

Aerilius, it was the graphic driver. I installed the latest version and now the mouse works as expected.

Thank you soooo much!


#5

My SU15 works as expected. The SketchUp window might have to be the focus (if another window is the focus the first click sets the window in focus then another click will select what is behind the pointer). On my system (Windows7 Pro SP1) I do not even need the SketchUp window to be the focus but I have experienced similar behavior with other OS versions and other software too.