Modelling Kreg pocket screw holes and screws

[EDITED from the original, in the light of experience developing the components. This post contains the latest two, which work as expected.]

I’ve done some work on making Kreg pocket hole components, in the end settling on two variants.

They replace my former 3D Warehouse Kreg pocket holes and screws components, with greater ease of use, and have been uploaded there in their (hopefully final) current form.

The final two versions, each contain eight separate Kreg pocket hole components, one for each of eight finished size board thicknesses.

Board thicknesses range from 19mm to 44mm (almost exactly 3/4" to 1 3/4").

To use these components, OPEN either, explode and delete any size you don’t plan to use, leaving up to eight separate components. You can save them to a component collection, or just copy and paste them into your model, as needed.

  1. Basic pocket hole component, which will Glue to Any face, and Cut Opening. After placement, with rotation if needed, you can explode it to merge its geometry into the board but that isn’t necessary and may not be helpful. It will not expand the bounding box of the board, whether exploded or not, and this variant should be used (unexploded) if you want to use a CutList extension to list board and fixing sizes and quantities in a full model. Each component contains a Kreg pocket hole, and a low poly 3D Kreg screw head, but no screw shanks.

  2. The same pocket hole component, this time with the addition of four lengths of Kreg screw, with the same 3D screw head, and 2D Face Me screw shanks of different lengths. The screw length is selectable by R-clicking on it, then choosing Dynamic Components/Component Options from the context menu, then selecting the length from a drop down list of lengths: 30mm (1 1/4"), 38mm (1 1/2"), 51mm (2") and 64mm (2 1/2"). You can also choose not so show any screw parts, or only the head. This one can’t usefully be exploded. It is useful if you want to show an X-ray or cut-away view of the Kreg jointed assembly, and/or to check whether the screw length you have chosen will fit within the board it is screwed into. But it will expand the bounding box of the board it is inserted into, which will be problematic if you want to use a CutList extension for board sizes.

To use, open a board for editing, and drag one of the components from the Component Browser into the board, placing its origin (marked by a guide point) on the edge of the board. It will glue to the face over which the cursor is hovering when you click to complete the insertion. You need to be careful not to move so far from the edge as to lose the Edge inference.

Rotate about the guide point, in the plane of the board surface to align the hole correctly if necessary.

The first type can be exploded to merge the geometry into the board. This should not affect the bounding box or component listings in a CutList plugin. But you will need to set the options in CutList to show Kreg* as a Fixing or equivalent.

It works more easily in Open CutList from the Extension Warehouse than in the CutList 4.1 also found there. The latter only lists the lowest level in the component heirarchy, and so won’t list a board with subcomponents in it. In the latter plugin, exploding the hole, and merging its geometry with the board will work, if you also move the screw head and screw shanks outside the parent board.

Here are the SU models of the two types, saved back to an older version 2014 to make them more widely usable. These versions are revised from the original post to correct various minor size errors pointed out helpfully by Claire Z (@ct103stu0) (see below).
Kreg pocket holes and screwheads v2014.skp (271.6 KB)
Kreg pocket holes and screws DC v2014.skp (303.4 KB)
And here are images of the two types inserted into a board in v2014.
Type 1 - no screw shanks



Type 2 - with screw shanks, default length appropriate for board thickness

To use these components in v2014, you will need to update the built in Dynamic Components extension to at least v1.5 (it shipped with v1.3). If you don’t do that, after inserting a Kreg component, double clicking to open anything for editing will trigger two successive errors

Search older topics in this forum for how to install extensions manually.

4 Likes

John, I am new to SU. When I download the DC version and then use the hand tool and mouse over the component, there is a red “not” circle. How do I get the DC options to appear? First time using dynamic components, obviously !

Right click on the component, then choose Dynamic Components/Component Options.

Tried to upload an animated GIF for you, but the option was greyed out when I tried to capture the action.

Looks as if you clicked on Component Attributes instead of Component Options.

Nope, maybe not, looking again. You did that once, exploring, but when you tried Component Options, you got a blank window.

Try again. Open a New model. Then File/IMPORT the dynamic component, don’t just open it.

Then try R-click again.

If that doesn’t work, it’s sometimes because, depending on how you load the DC, it may get an extra component ‘wrapper’. Try selecting the component and exploding once.

Take a picture of that part of the screen and post it here. If you see only one component highlighted, try R-click on that. If the explosion was of the component itself, not an extra wrapper, you’ll see the constituent components highlighted in blue instead. If you see that, UNDO (Ctrl-Z or Command-Z on Mac, which I see you are using).

Did you see my GIF? Does the component need to be inserted into a group as your model? In my GIF, when I select Component Options, I get a blank dialog box.

Exploded the component once, the options dialog box is still blank …

Downloaded the component directly into the model. Here it is, I downloaded just the file from the 3DW.

Kreg pocket hole and screw DC v2014.skp (152.6 KB)

We’ll keep at it until we get it sorted.

Are you planning to use an Xray view to show the screw shanks? If not, you’ll find it simpler to use the non-DC version. From any other normal view you can’t see the screw shanks.

Where from? My forum post, or more likely from the 3D Warehouse?
Then try downloading it to your Downloads folder, then File/New, then File/Import.

I’ll try it myself from the 3D Warehouse copy of the model, into a new model here, and tell you what happens here.

I downloaded it again (3DW) and attached the file, see previous post. Attached here as well …

Kreg pocket hole and screw DC v2014.skp (152.6 KB)

The option dialog bug ( where nothing pops up) can be annoying.
Close SketchUp and open the file again.
This time, only use right click to open the Dynamic Options dialog

Well, I did what you did, and it worked for me. So let’s think again.

I just downloaded your uploaded copy, double clicked on it, and it opened immediately. R-click, and the Options window is working here from that, too.

I see you are using (or at least downloaded) your copy as v2019, but that shouldn’t make any difference.

Temporarily stumped.

Tried opening it in v2019 (which like you, I also have).

I get the same behaviour as you do. So, bug in 2019 DCs perhaps?

Thanks. This is way beyond my level of competence :upside_down_face:.

Mike, thanks for pitching in. I haven’t encountered this bug before and doing as you suggest still gives me a blank options dialog. And exploding the component does just that - it’s not double wrapped.

How can I report this? And more importantly for Claire, how can I fix it so that it works in 2019 which she has?

I see when I look at the Component Attributes in 2019 that the top level component has lost its options attribute. I’ll try to recreate it and upload again here in a few minutes.

No, it’s not that. It’s worse, it’s lost its outer wrapper.

Claire, try doing what I suggested a while ago - open a New file, then IMPORT the file you downloaded to your Downloads folder.

I’m going to try that here to verify if that’s the issue.

1 Like

What version of DC? (Extension manager)
Have you tried to uninstall the DC? Close and start SketchUp again, it should (re)install the shipped version. (1.6)
But since 2020,the extension got updated (1.7)

I checked in my SU 2019.3 Extension Manager that it has no DC extension update available, and is v1.6.0.

Should I try to update via browser download from Extension Warehouse to fix this?

HMMM.

The component in the Warehouse has lost its component wrapper.

Claire, try downloading from earlier in this topic. That might work. I’ll try to fix the Warehouse model tomorrow, and in the meantime, get one to you that works.

Give me a few minutes.

Nope, that doesn’t work either - Import of the download from earlier into SU 2019 just gives me File not found or invalid.

???

Well, my original works. I’ll upload it here for you now, Claire, but will have to fix the Warehouse one later.
Kreg pocket hole and screw DC v2014.skp (148.5 KB)

Download this to your Downloads folder, open a New file, then IMPORT it and see if that works. It did for me just now in 2019.3

1 Like

Stretching mine, too - nothing here was your fault, or lack of competence. Something I did earlier just didn’t work, for no reason yet obvious to me.

It’s 12:30am here and I have to get off to bed. Will try to check things out tomorrow, but not free until the evening.

|n the meantime, try the earlier links to my DC model if you want the screw shanks, or to the plain hole, or hole plus screwhead if you don’t need the shanks. I’ve updated all of them in the last few minutes, with versions that work here. Not sure yet about the Warehouse versions. I have updated them, but won’t have time to test before tomorrow night.

But remember to download and File/Import, not Open. The latter strips off the outer wrapper of the component.

1 Like

It doesn’t strip it off, it just opens the component for editing.
Same way if you save as a component, then open that saved model you are inside the component ready to edit it.

1 Like

Thanks for that clarification, @Box.

In the past few minutes, Claire, @ct103stu0 I found the time to check that the Warehouse versions of type 2 and type 3 components DO work, if downloaded as v 2014 (or in your case 2019 would do too) and Imported into a new file in 2019.

Will probably work in earlier versions back to 2014 if you choose that version to download. But I’ve only had time to test in 2019 tonight.

So try again, if it’s not too late for you where you are (your profile doesn’t say).

1 Like