Model not opening properly and then crashes

The model used to open without a problem, but now no longer opens properly. The file opens, but i don’t see anything and then if i try to move around it freezes. It is a large file 246MB. I have a Samsung Galaxy S21+ with Android Version 12. Also, i sent the file to my girlfriends iPhone and it opens fine for her. I have tried reinstalling the app but it crashes the same. I reported the crash.

Thank you for any help.

That is pretty big for a file that you want to look at on a phone. Do either of you have SketchUp, where you can check what it is that is making the file be so big?

It may be that you’re using materials that are bigger than they need to be, that would add to the file size, and would take up a lot of GPU memory on the phone.

If you don’t have SketchUp, can you post the file online somewhere so that we can look to see what is making it be so big?

Here is a Google Drive link to the file.

It’s a house that i am renovating and i have added several models from the 3D Warehouse and Geo Location. I will look at trying to reduce the file size, but it was actually running quite nice in Viewer before and the file size was basically the same.

Thank you for your response.

That model is very large, having over 2.4 million edges, 1.3 million edges, 3500 component instances, 480 materials, etc. Although it loads on my Mac, it needs about 3 GB of memory. I suspect it is simply too big and complicated for the Android device to handle. I don’t know what you have been doing to the model recently, but it appears that something pushed it across the limit for that specific device.

A major contributor to the size of your file is “entourage” elements, most likely from the 3D Warehouse. Those models are notorious for issues when imported directly into a user model. They tend to accumulate as you experiment with features to make your model prettier unless you purge regularly. Also, always download into a blank model and then examine the result to see whether it suits your need or is bloated.

Here are some things you can try to slim the model down and see whether that allows it to load:

  • Purge unused items. When I did this it removed 211 unused components and 144 materials. That shaved about 70MB (about 28%) off the file size.
  • Using the Material Tools extension, I found multiple materials in the model whose texture images are large (over 1M pixels) and use image file sizes over 10MB. Unless those images are mapped to large objects where the details will be visible, their detail is wasted. They could be replaced by simple colors or lower resolution images with no detectable difference in the model. As an absurd example, I found one material (“tecido_brandon1”) which uses a 1024x1024 texture image but is used only by an edge where the texture can’t possibly be seen and even the color won’t show unless edge color by material is turned on in the active style (it wasn’t in your model).
  • Re-examine all the entourage elements you have added, asking yourself whether they are really essential to the message you are trying to convey or could be either simplified or eliminated without loss of useful information. The main question involved is whether there will ever be a view of the model in which the extreme details will be visible and necessary. Typical culprits are interior features of components that can’t be seen through the outer surfaces, and small things that you would have to zoom in very close to see as anything but a blur. There are vast numbers of models in the 3D warehouse that are good as standalone, but far over-detailed for use as entourage.
  • You have a lot of items using non-visible tags. These are also candidates to re-examine why. Is is because they aren’t really needed or because that was necessary to make the model manageable. SketchUp is quite efficient at ignoring non-visible items while drawing to the screen, but they still take up space in the model.

Thank you so much for your time and insights. I will DEFINITELY follow your suggestions and work to reduce my file size.

However I do think there is something else afoot as the file opens on my girlfriends iPhone which is much older than my S21+.

Thanks again. I will report back after i reduce the file size.

Unfortunately there are enough differences in hardware and OS that ability to open a heavy model on one system doesn’t assure it will open on another.

Turning Profiles off is a good idea for performance. You do have a lot of larger textures, here’s a file where the only changes are to turn off Profiles and reduce the size of the materials a bit. See how this gets on with your Android phone.

I was able to bring my file size down to 106MB, which I’m really happy about; thank you. Viewer however is still unable to open the file…

Hi Colin, thank you so much for your time. I tried opening the file after your adjustments and the same thing is still happening. See attached screenshot.

I don’t know of a reason that dimensions would affect things, But here’s a version with less dimensions: