Model Lost in space. Can't zoom, draw, or anything

My model is lost in space I guess. The entire thing was so messy because I was modeling furniture for a lot of rooms but it should all be in the same area. The issue is all I see is green. I tried to draw and couldn’t do that either. I also tried importing the model into a new one because that is something I read but it just showed up as a gray rectangle and now, nothing. Also when trying to print nothing shows up on the page anywhere, so I think its just gone.

Doesn’t look much like a bed but this is what I see after fixing the camera.

bed[1].zip (10.5 MB)

That’s the entire thing?

I didn’t save it but I started deleting those giant insect wings and found a mess of images and other smaller stuff. I had no idea what you actually want out of it but I never did see a bed. You could do the same and delete the loose geometry a little at a time and see what you find that might be useful.

I want all of it or at least most. I had chandeliers and lamps and foundations for chairs.

I just can’t figure out how to aim the camera or how you else able to get to the piece you uploaded.

Did you open the .skp file I shared? The Camera is already aimed as in my screenshot.

Look inside the Components tab, there are a couple of compnents named ‘bed’, 'chandelier chain but thats about it

’ etc