Model Info & Preferences Dialog Boxes now don't display

Started this thread trying unsuccessfully to adjust Animation settings. Tried 2 different ways to invoke the dialog box I was expecting, but SU “acts like” it should be visible (pings when you try to do something else until you ESC out). So I read about how to Use the Model Info dialog box to get into Animation settings. Whups, cannot launch a Model Info box either. I am looking at my Entity Info box displaying okay on my second monitor. Then read about trying to reset the Desktop via Preferences. Uh Oh… Preferences will not display either. Ideas/Help?

Sounds like SketchUp’s notion of the locations of windows has gotten screwed up, which sometimes happens on double-display systems especially if you disconnect one. Try Preferences->Workspace->Reset Workspace and see if that helps.

The dialogs are opening off screen, you may have changed your monitor setup recently.
Go Window Preferences, to make the dialog active, hit alt and shift together, then m, then tap any arrow key, now move the mouse around without clicking until the Preferences dialog appears on your monitor.
Use the workspace reset button to get the rest back.

Thanks all. I got the solution idea here in Community and then solved the problem this way. In Windows 10 I found control panel (thanks Microsoft for burying it now), changed from 2 displays to 1. Applied settings. Then put it back to 2 displays. So all SU dialog boxes are visible again!