Model info no longer drops down?

Came back from vacation, and when I go to window, model info, no panel appears? all other panels appear, but model info doesn’t.
have done updates, uninstalled and reinstalled, checked older sketchup files and all are the same, no model info from the tool bar.
I can change using the default tray entity info, but that is frustrating to do it for every dimension or text I need to add.

This has nothing to do with any specific models. Sounds like the Model Info panel is opening off screen. Did you have a second display connected to the computer?

Can you open Preferences and go to Model Space? Try clicking reset Model Space.

If that doesn’t work Click on Window>Model Info and then while it has focus, press alt and space together, then m, then tap any arrow key and without clicking, move the mouse around until the window appears.

You shouldn’t need to be going to Model Info to make changes for every dimension. If you have to make some change to dimensions for every SketchUp model, you should create a template with that change already made so you don’t have to attend to it every time.

reset workspace worked!!!
thanks a lot

1 Like

nope, worked one time, now we are back to no new window for model info
Tried the workspace reset and no change now.

In addition, now it locks up when trying to create a component. Task manager shows it isn’t locked up, but nothing on the screen will respond unless I close sketchup with task manager and restart.

I uninstalled sketchup and reinstalled an older version of 2021 pro from Feb, and no change.

Again, probably the Create Component panel is opening off screen. Pressing Enter probably unlocks SketchUp, too.

When you installed SketchUp did you right click on the downloaded installer and use Run as administrator? At this point I would suggest finding the installer or downloading it again and repairing the installation. Quit out of SketchUp, right click on the installer, choose Run as administrator and then choose Repair. If you need to download the installer go to