Model disappeared, just grey working area, even without axis and stored scenes will not do either

SU2021 Pro
Experienced user (+13 years)
This has never happen before (alot of program crashes, but no disappeared model)

I have searched form for answers, but no answer explained WHAT to do, just helped user.
The model is huge, 70Mb, and contains alot of repetitive objects.

Model diapered completely during modeling. Just a grey box inside SU window. No axis can be seen.

What I tried

  • I have tried using the fixed scenes (that moves camera, turn on layers, show hidden etc).
  • I have tried to switch styles, but it will only change color of the grey working area.
  • Using Outliner I have hide all objects, except one and tried to zoom to extents on that object.
  • Using basic tools like Line and Rectangle doesen’t show anything when using.
  • Top view, side view, iso etc.
  • Unhide All
  • Show all Tags
  • Saved model to SU8 and opend it in SU8 with exactly same results.

Sensitive data
The model contains business sensitive information and I can’t publicly upload it.

What I want help with
What to do? What to look for? Is there any recovering Extensions?
For me I can manage this time, but if this happens again, what to do?

If all of your model behave like that, The "No axis can be seen." and the “Using basic tools like Line and Rectangle doesen’t show anything when using.” symptoms mostly because your graphic driver is broken, usually by windows update…

Perhaps You can try to go to Window>>Preferences>>OpenGL and try to toggle the “Use fast feedback” checkbox. (You may need to restart SU to take effact.) …if that make difference…

You can go to your computer manufacturer site to download and update to last graphic driver.

The other thing I would try to select all the objects using only Outliner and hit ctrl+c then paste in place (or just paste) into new empty SU model…

Try cut and paste the following file into the SketchUp Ruby Console and then hit return. It repairs a lot of issues that can potentially make a model seem to vanish. It was written by @sWilliams .

RescueMyModel v12.rb (4.4 KB)

Thanks for your suggestion, BUT I can model the version before crash and after remade what I lost I can still model as I should. This makes it rather sure that it is no problem with graphics driver.