Model disappear when I orbit

Hello everyone this is my first Topic ever.

My name is Mattias, I live in coold Sweden :slight_smile:
Soon i will start my “garage buliding project”

Iam first creating the garage in sketchup. iam almost done, but there is som issues when i orbit around.
The whole model disappear and its hard to find it again. I have tried diffrent things i found on youtube.
Nothing hepls…

Can someone please help me? take a look at my model and see whats wrong?


How about sharing the SKP file so we can see exactly what is happening?

First thought without seeing it is that you have what is known as clipping. There are several reasons this occurs. One is that you are working in Parallel Projection instead of Perspective and the camera is positioned too close to the model. Try switching to Perspective and hit Zoom Extents.

cp kamera.skp (1.4 MB)

Sorry… forgot that :slight_smile:

Copy the model and paste it into a new SketchUp file. I think you’ve got something corrupting this one.

Thank you so much ! Can you se whats wrong? :sweat_smile:

I’m still looking. I see some issues with your model of the garage but by themselves, they shouldn’t cause this problem.

hahaha… sooo simple :slight_smile:

Thanks !! Now its working… i call this BUUUGGG :wink:
You are my Hero DaveR

I wouldn’t say for sure it’s a bug but it is unexpected. At least you’re back to working again. Good luck with the garage and keep warm.

It’s very odd, it won’t respond to my 3d mouse, then if I switch to orbit with the toolbar and move around it bugsplatts.
But copy and paste was my suggestion too as that works.

Another odd thing I see is that changing to different standard views doesn’t change the axis display. It remains in the Top view. Switching from Perspective to Parallel and back seems to fix that but it doesn’t stay fixed.

There is a text entity that somehow has gotten its position set immensely far from the origin. When I erase that entity the model returns to sanity.

It says “P1 Limträ 0,14x0,14 m L2313mm”

cp kamera.skp (1.5 MB)

Excellent! I figured there had to be something at a long distance from the origin but I hadn’t found it yet. Steve to the rescue!

I also have a model with this problem and suspect a far distance object as I have an imported dwg file - but how did you manage to find this far distance object? I have tried to scroll out in my file - but can not find anything…

Back when this topic was active, there was a bug in SketchUp that could cause leader texts to fly off toward infinity when you edited the face their leader attached to. But that bug was fixed in SketchUp 2019, so if your forum profile is correct I doubt that is what you are encountering.

Distant objects are a common problem with imported dwgs. Sometimes it looks to be from working in UTM coordinates in AutoCAD, in which the origin will be at the corner of a zone and the northing and easting distances from that corner may be quite large. Other times it just seems that AutoCAD encourages people to scatter contents over absurdly large areas.

But there are other things that can also cause issues.

Can you see any part of your model? If so, since your profile says you have SU 2020, you could try dragging a selection box around the valid contents in your model and then doing Edit->Invert Selection (this command isn’t available in older versions). Look at Entity Info and see what it finds. You may be able simply to delete the distant selection to fix the model.

If you work in parallel projection, have you tried changing to perspective and then doing zoom extents? Modeling in parallel projection can lead to issues with the camera position and zoom extents in parallel will often restore a sensible camera.

@sWilliams shared the following Ruby script that can repair several kinds of issues with camera position and distant objects. To use it, copy and paste the contents of the file into the SketchUp Ruby Console and press return.

RescueMyModel v12.rb (4.4 KB)

If none of that works and you can share your model skp, members will take a look at it to diagnose the problem for you. Files smaller than about 15MB can be uploaded directly in a reply. Larger files you need to put on a file sharing site, make them public, and then share a link to the share here.

Thank you Steve for replying on this. The dwg is in this case quite small and limited and grouped. I do see it from top view in each scene I have created but it “disappears” the moment I try to orbit - even if I have tried as suggested in this thread to change between parallel and perspective. I have also tried to change style as I thought my modified caused problems. It is a small file so if you would take the time to have a look at it - I would be grateful. I can redo it all from scratch using pdf instead of dwg - but kind of annoying not understanding what I do wrong…
Norra Amerika.skp (262.0 KB)

See if you can make this work for you.
Norra Amerika A.skp (178.3 KB)

It appears that @DaveR fixed it for you before I got back, but I took a deep look anyway.

This is an interesting test case model, with a variety of flaw I haven’t encountered before. The group that contains components named “Norrpil” and “Skalstock 10m” has somehow been scaled down to atomic size while offset from the model origin by a non-zero amount. For some reason that combination was driving SketchUp crazy (seems like a bug). In Dave’s model, it is scaled even smaller, but moved to the origin, and that appears to make SketchUp happy again though you can’t see that group no matter what you do. Even selecting it and doing zoom selection doesn’t make it visible!

I took a different route and scaled it back up to 1.0 using a Ruby code snippet and then moved it to the origin. It looks like this:

From this result I deduce that it was a north indicator and scale bar from a map. I can’t tell whether it was so tiny in the dwg you imported, got shrunk during the import, or was shrunk by something that happened after import.

Here’s the model with that fix in place. I didn’t bother to purge unused elements, though Dave did, so this file is larger than the one he shared.

Norra Amerika.skp (292.8 KB)

1 Like

Oh this is interesting to know! The scale bar is “mine” and I have it pre-placed on several scenes in my SU template. so these where there when I chose which template to use when I started with the dwg import. Hhhhmmm wonder if I made a mistake when importing or if it all got screwed when I resized the imported dwg - clear is that I should have taken these components out from my template. Thank you so much for you time and effort on this both Steve and Dave - have a great weekend!

1 Like