Model creates unstable layout file


#1

Hi,

I have a model of a site plan with multiple buildings that is relatively complex, but not too large (40MB). I am trying to create a layout document with multiple pages of various perspectives, elevations, and floor plans. I am able to send my scenes to Layout, but the resulting document is highly unstable: super slow, pauses constantly, and freezes when I try to do almost anything. After trying many things, it appears to me that there is something about this particular model that is causing problems. I am able to create layout documents from other models that don’t seem to be glitchy. I have also tried working on this model on a different computer and I have the same problem.

Anybody have any idea what the problem with my model might be? I am at my wits end.

thanks for your help,

Matt


#2

Is the model very far from the SketchUp model origin or does it have parts (or stray lines, for instance) that are very far? These kinds of problems often happen with models based on imported CAD map files. Or is the model itself very large (like several miles/kilometers across)?

These create problems with the OpenGL display system that underlies all views in SketchUp and LayOut.

Anssi


#3

Thanks Anssi,

No, I just double checked. The model is located near the origin and doesn’t have any stray geometry. Everything is contained in a 400’ square with a corner touching the origin. I checked that by hitting zoom extents.


#4

some random ideas:

  • Purge the sketchup file. Maybe there’s unused textures/components that increases the file size.
  • Make a temporary copy of the sketchup file. Delete half of the objects and geometry. Re-link your layout file to this new file. If the layout file is snappy again, your problem might be in the deleted elements. Repeat the process, while deleting only 1/4 etc. If not, try deleting the other half and test again.
  • if the above fails, copy all your objects to a brand new sketchup file and set up the scenes from scratch again. This step probably doesn’t make you happy but if the above fails, this might be the only option left…

#5

What does the complexity consist of? In my books 40 MB is enormous, especially if you use a lot of components. What is the edge/face count in SketchUp (Model Info>Statistics>Show nested components)? When it starts to run in millions or in the high hundreds of thousands, any model will behave sluggishly, whatever your computer hardware.

I think that I managed to create an “almost-sketchup-killer”-file that is less than 2 MB:400trees.skp (1.7 MB)

Anssi


#6

Thanks for all your help. It looks like there is something in my model that makes it choke when I try to vector render my floor plans, even though there looks to be nothing but line work. I think I will try to create a separate line work viewport using “make group from section plane”. Hopefully that will make it happy. Thanks again for helping me out.

matt


#7

Which version of SketchUp and LayOut are you using?

One thing that I find helps to speed things up when rendering in Vector or Hybrid in LO is to make sure that I turn off layers for as much stuff as possible when I make the scene so LO doesn’t have to look at edges that aren’t visible in the scene. For an exterior view, that means turning off layers for interior details as well as for entities that might be located behind the camera. Reduce the amount of stuff LO has to parse through for rendering.


#8

2016… I will check that out. I definitely tried to strip down the model as much as possible. The thing that was odd to me is that my model would eventually vector render, but the program would continue to be unresponsive. I would think that once the viewport rendered, Layout would be able to treat it like another image file and it would not be resource intensive. Clearly that is not the case.


#9

Vector rendering tends to be very intensive unlike raster rendering. It is much faster these days with SU2015 and SU2016 but with a lot of edges to render (even if you can’t see them all) it can take awhile. It used to be that I would save vector rendering until I was finished with everything including modifications to the model. then I would start the rendering and go eat dinner or do something else useful. Now, most of the time I don’t even have time to refill my coffee cup before the rendering has completed.

Part of the way I organize layers in my model developed from working out how to reduce content to be rendered for various scenes. Effectively it’s like making a theatrical set piece for each scene. If you can’t see it in the view, its layer is turned off.


#10

Vector or hybrid rendered models tend to be slow in LayOut because the vector rendering process in effect creates lots and lots of LayOut Path objects. These objects are functionally hidden unless the user “explodes” the model after vector rendering, but they are there. A raster-rendered model takes much less processing power to display because it is just an image - although the danger with raster is that a large high-dpi image will occupy a LOT of contiguous memory.

These factors combine into the rule of thumb for working in LayOut - use raster models on a lower quality setting for working, switch to vector rendering only as necessary, and then turn up the quality for final output.

-Marc


#11

This makes me think of a feature request. I always set my Display resolution to Low and Output resolution to High. Could it be possible that in this case LayOut would use Vector and Hybrid rendering only for output (to PDF or DWG), as screen viewing or image exporting do not usually need it. So for Low resolution, LO could turn all views temporarily to Raster rendering.

Anssi


#12

Thanks to everyone for your help. Much experimenting turned up a single object in my model that was causing the problem with vector rendering in layout. Hiding it makes everything work smoothly…almost. My new problem is that when I vector render my section cuts for floor plans, the model becomes transparent to layout so that lines that should be hidden by objects in the model are rendered in layout. My first floor renders correctly, but my second floor renders both the first and second floor line-work, and my third floor renders 1st, 2nd, and 3rd floor line-work. I am sure there is something obvious I am doing wrong, but I can’t figure it out. Any more help would be greatly appreciated.

All the best,

Matt


#13

That turned out to be a hardware problem… Something about my graphics card.


#14

Very helpfull, change form vectors to rastrerize and works again, but in the style of the model I set the line weight to .25, in the scale of my layout help me to be more accurate.