Missing Embedded Images and Scene Views

layout

#1

Layout seems to randomly forget how to access the embedded images or embedded SketchUp Scene Views. Super annoying to say the least when presentations are due. It’s not one or two, but 20 or more. Used “Insert” for all items. Typically have to find an old back-up and copy/paste the missing embedded images/ scene views. Other “linked” images and scene view seem to be okay.

Something on my end? Easy way to show the file where the embedded data is? Thanks!

SketchUp/ Layout 2016, MacOS 10.11.6, MBP. File is stored locally, backed up to an external drive via Time Machine.


#2

Hi,

under. . . >File >Document Setup >References; what’s the check box status for ‘Check References when loading this document’ set to?


#3

Hello. That option is checked on.


#4

Hi xdcmx-

We’ve had one other report of this behavior lately, so we’re very worried about it but we haven’t figured it out yet. It seems to be consistent for a very small group of people but we don’t know what makes it happen for them.

One word of advice for handling this behavior:
The .layout file is secretly just a .zip file. If one of your inserted images/views disappears, you may be able to unzip your .layout file and recover the missing insert. I’m very curious to know if you find that the missing files are still there most of the time or if they’re actually missing from the folder.

Thanks,
Marc


#5

Oh, also, if you find a way to make this happen consistently, I’d love to hear the exact steps.

-m


#6

Ok, one more question: does this happen while you are working on the file? Or do you only see it after you’ve done a save & load?

Thanks!
Marc


#7

Hi Marc,

The missing files are not in the “ref” folder of the .layout converted to.zip file. The References list shows the file name is also gone as shown here…

-Dennis


#8

Marc,

Happens after a save and load- not every time. And I’d rather not discover a way to make it happen consistently!

-Dennis


#9

Are you using Insert multiple times for the same SkethUp file?


#10

Sometimes. Most of the time a copy/paste a window and change the view to another existing scene. Most of the missing items are image files of various types with the red crossed out gray box. Some missing items are SKP views I embedded as I wanted to retain an old model version- these are now missing with the yellow exclamation point triangle.


#11

Happened again. This time, the document was open in the background overnight. The backup version was saved a few minutes behind the last main file save and is okay. Closed the file, made a copy and converted the file to .zip. Looked for one of the image files in the ref folder and it’s there. Opened the original file back up and everything is now there.


#12

This is happening with my Layout Docs lately as well. Found this thread looking for an answer as to why.


#13

I am having this same problem with missing files on Layout documents. I just worked on a file Friday and everything was linked up. This morning I opened the document and had 11 out of 21 files listed as missing.


#14

Bummer. It was still happening to me over the last month (during deadlines of course). Just updated to 2017, crossing my fingers it goes away! Any updates Marc?


#15

Similarly to these peeps and nlenn in other post, random embedded images missing, greyed out with red cross, no option to update image reference, unarchived file does not contain missing images. Anyone learnt anything new?


#16

Any news Marc? This is getting really old and costing valuable resources! EVERY embedded image missing this AM. Was hoping v2017 would resolve this.


#17

Has anyone solved this as yet… I’m really stressing here as I have a full presentation of red x


#18

I would love to know if there is a fix for this. I just lost several days worth of work because of this same problem.


#19

I’ll ask the same question I asked another person who had this problem.

Are you using File>Insert multiple times for the same SkethUp file?

What is your exact procedure for creating viewports in LO?


#20

Yes I am. I save my SketchUp file with the view I want then go to LO and File>Insert the SketchUp file. I then select “last saved view” and embed the image so that it does not update with my SketchUp file.
I know this is not as clean as using scenes but in this instance I felt it served my purpose better. I have done it many times before with no problem. However, this time when I opened layout all my reference files were missing.