Embedded images


#1

embedded images get lost?

checked : C:\Users\nenle\AppData\Local\Temp…nothing there…wiped completely. They should be embedded thus saved
with layout file??

Any ideas…


#2

Did you look in the Layout file itself?


#3

Don’t understand what you mean by that…Open file and places where images reside greyed out with red cross…try to relink by going into the file as per above but no references…happened before and I managed to relink, not this time…completely retarded…I could write a book about complaints but it all fall in deaf ears…This time I just thought somebody might know the “secret”…I have had this communique with John Bacus sometimes ago with no luck…He didn’t even realise that things like skalp could exist…but that’s a different topic… I’ve been using Sketchup since 2003 and can’t believe how slow is the progress…Complete rewrite, true solids, fully structured geometry, Fully integrated BIM…Not this ■■■■ scenario with hollow product and millions of extensions trying to make a nag true thoroughbred…Sorry for this emotional offload…AutoCAD/AutoDesk will most probably create something similar …However I’ll still be using Sketchup and sadly Layout - Utter Mickey Mouse, let’s be honest… One day they might be one, but with this pace humans will be living on Mars by that day… Have fun!!


#4

Hi Nlenn-

Thanks for joining our forums and sharing your views on our product!

Regarding the images, yes, LayOut should copy all inserted images into the .layout file. LayOut has the concept of an “external” file reference (a reference to any file on disk) and an “internal” file reference (the backup copy that has been copied into the .layout file). In the event that the original image file is moved/deleted, or if the .layout file is moved to a different machine, LayOut should load the image from the internal location instead of the external one.

I would not expect to see the ‘red x’ during normal operation. Are you deleting/moving the inserted image file while LayOut is open? Are you manually making changes to anything in the “temp” folder?

thanks,
Marc


#5

I have opened that file to use these images…Done nothing to it…Luckily, have made a PDF beforehand so I can issue it to the client. This is constant problem. Happens with images that I capture and paste in Layout. Once saved they should be embedded but they disappear altogether. If I have to save them first and insert then that’s retarded. Defats the objective altogether…Not a first time. I open some old files images are missing. Have posted this some time ago with no solution…Pretty lame as many other things for quite some time now…The idea behind Sketchup is great… but from my perspective it’s just a glorified idea… we should really move on with some serious pace to put this product on it’s feet finally…Amongst other things Layout is missing a great deal of stuff to make it fit for the purpose… You know this…The real shame is that at this point in time these “trivial” things are persistently happening…Especially if I have 20 pages with 50 images gone and have to issue drawings…Nice?!


#6

This is the screenshot …more than 20 images wiped from the disk…the reference directory is empty…Again…this happens all the time…Please can you check this out and come with some solution. I don’t think I am the only one…These images that come from the clipboard are disappearing from the disk…nothing to ref to??? OMG!!! I have just finished this project…The worst can’t remember what they are as I’ve picked them up from the web…


#7

another shot


#8

Helloooooooooooooo, anybody out there, Maaarc, DaaaveR please talk to big daddy about this retarded stuff and come back with some answers…bugs everywhere…


#9

I have created a scrapbook in layout with all the stuff that I’ll be using, but they have disappeared from the scrapbook as well!!! Actually it doesn’t matter where they come from i.e. clipboard, disk, link etc. they all disappear…they are not embedded…This is chronic problem…My workflow depends on external content…Please advise is there any other way to preserve these images as it happens quite frequently, after file is saved. Does purge command accidentally purge these images as well…And also why they’re not embedded in layout file?!..this “temp” stuff is very odd anyway.

Regards

Neno


#10

I’m having this exact same problem. Another thread noted that .layout files are zip files so I compared an archived copy of the layout file to the new layout file (changed the extension to .zip) and the greyed images with the x on them are in the archived version but no longer in the current version. This causes the current version to show a ‘/’ for the filename as shown previously in this conversation. Any idea what would cause these embedded images to be erased/deleted?

My images are not sketchup saved views, they are images cut and pasted from PDF files and appear as png file names when viewed using the .zip version of the file. For example, “4001948205_Clipboard Image 177_7769.png” is in the archived file but no longer in the current file so shows up as a grey box with a red x on it.

I never had this problem with 2016-2017 but it is occurring with drawings created in 2017 and opened using 2018. I haven’t done enough projects started with the 2018 version to know if it also happens with files created using just 2018.

Tried a quick experiment and restored the archived file and opened it in 2018 and everything is there. I’m at a loss as to why the embedded images are disappearing.


#11

This is the problem. It would be better to copy the image from the PDF and make a PNG in an image editor. Then use File>Insert to add the image to your LO project. When you copy and paste into LO, there’s no permanent reference.


#12

I get your point, but as an average user how would I know that. I go to my PDF, window an area and select copy (I use a program called Bluebeam so it’s actually called snapshot), then I go to layout and select paste and everything looks great. Fast and easy. If the correct practice is to not paste images into layout but reference them in, then the program should either not allow the option of pasting images directly or make the user more aware of the limitations of that feature and that pasted images may be lost.

I understand your last statement “When you copy and paste into LO, there’s no permanent reference”… but I can open the archived layout file as a .zip file and show you there actually was a .png file that existed at one time. I guess you could say that is not permanent but that would mean any file on your computer is not permanent. My guess is layout for some reason thinks the images are not used any more and is purging them even though they are still used. Yes you are correct if I referenced them then technically layout should not delete them but that adds a lot of time to drawing creation which I’m trying to avoid.


#13

I’m just telling you from years or experience with LayOut and trying to save you a bunch of headache. Trying to shove you farther up the learning curve you might say.

We see this sort of thing occasionally where users are creating files that don’t have proper references and then they lose the images. I’ve seen more problems from users inserting Sketchup files incorrectly which can really wreak havoc.

Most computer programs as well as most other things will let people do things in ways that aren’t the best practice. LayOut isn’t unique in that.


#14

Dave,

Gremlins are coming back. The whole issue revolves about “embedded” as I’ve mentioned to you long time ago, 4 years I am having this stupid issue. Each time I open layout file I am waiting to see vanishing “embedded” images. That is a bug in the software and you better not try to explain it as more you try the less it makes sense…

Embedded dictionary meaning:

to fix into a surrounding mass:
to embed stones in cement.
2.
to surround tightly or firmly; envelop or enclose:
3.
to incorporate or contain as an essential part or characteristic:
A love of color is embedded in all of her paintings.

etc. etc. etc. “embedded” becomes a permanent/integral part of the context that is embedded in. That is not the case with LO. After 4 years still unresolved…In my case as I’ve explained before doesn’t matter how they’re inserted they vanish?!

I use over 20 different softwares and don’t have this problem whether content is inserted, referenced or pasted from clipboard… It always remains EMBEDDED!!!

You didn’t answer this question before and after all these years you still don’t have the answer!?

Have fun


#15

OK. I quit. All I can tell you is that I use a workflow like I’ve described to you and have never once had the problem you report. I’ve been using LayOut since the first version and have never lost a reference.


#16

DaveR, I’m sorry nlenn has come back but unfortunately I did hijack his/her thread as I am currently having the same issue. Perhaps I should have started my own thread but my problem is exactly the same so I figured this would be easier. Lesson learned.

I started using sketchup pro w/ version 2016 and have created many drawings in layout 2016 and 2017 and never had this problem until recently. I believe this may be a computer issue more than a layout issue since as you stated, you (and I’m sure others) do not have this issue. I agree with you that revising my workflow would fix this issue but I would love to hear from sketchup if that is the expected fix and that sketchup does not see any issues with what is happening to the embedded files and it is expected behavior.


#17

Hi Paul, same issue here. Lost 98% of all “embedded” images, replaced by big_red_X’s.

Dear Sketchup,

Love your work, big fan!! Kindly indulge a question from a layman concerning aforementioned “big_red_X” issue:

Is it possible that this ‘anomaly’ has something to do with the ‘/temp’ folder while Layout Application is open?

Scenario: an instance of Layout was open while I was performing some renders using Blender. I know Blender overwrites scope in the default “/tmp” folder.

Possible correlation?

Best regards,

André


Missing Embedded Images and Scene Views
#18

Hi Andre, do you know if blender is using any shared images contained in your /temp folder?

Also, have you experienced this issue when images are contained in any other location?

Trent


#19

Hi Trent,

only “resource” / “Location” shared during runtime is here: “C:\Users\Andre\AppData\Local\Temp”

I ran both programs (Layout + Blender) to see what temp folders are created and looks like Layout creates two and Blender One folder:

Thanks for your interest.

Regards,

André


#20

Dear Trent,

I also since I got bought the updated version am losing my images. It might work good for a while but a week later I come back an open my files and the images are replaced with a red x. Used layout for years before without this. Now feel like I cannot even use it. So sad. Not great with computers. Any suggestions? Any phone number I can call to talk to someone that can help? I have 2 separate 2018 pro versions on two different computers and I am quite sure I got the same missing images on both computers. I may very much want to get my older version back.


Embedded Images in Layout Disappear