Embedded images


#21

I too have had / am having the same problem. Mine occurs when I try to transfer scrapbook / template files from my work computer to my home office.
My thought process was to use a flash drive and download the template and the scrapbook I use most, and upload them to my home computer. Let’s say I uploaded them to my desktop:

When the files are first opened (from my desktop), all the images are referenced correctly & there are NO red X’s. However, as soon as I save it as a scrapbook, 1/3 of the images turn into a grey box with a red X through it. (But not all of them…?)

What’s even weirder is that if I open (1) a blank layout, (2) the LO-saved scrapbook, and (3) the desktop-saved scrapbook, I can drag the “Red-X” files from (2) into (1) and they will update the reference correctly. But if I close (3), they will still show the red X.

This makes me feel that LO wants to reference the initial LO file that was used to make the scrapbook, even though a new LO file is made in it’s place. What’s weird is the inconsistency of it since only 1/3 of the images get the X and the other 2/3 still work fine…

UPDATE: I still haven’t posted this but I actually just found a fix for my issues. Since my “desktop-saved” version was showing the images correctly, I manually moved that file into the Scrapbook save location at C:\Users\USERNAME\AppData\Roaming\SketchUp\SketchUp 2018\LayOut\ScrapbooksThis solved all red-X issues. So for me, it appears the LO save process is what was causing the errors?


#22

OK, so I have the same issue as everyone else. I also copy/paste clipboard items into layout. These images are then in the temp file on the local machine. When I save the file, all these temp items should be saved internally into the giant .zip file that is a layout file. I just did an experiment where I put in a new clipboard item on to the layout page, saved the file and closed it. The temp file is wiped as you would expect, and the new clipboard item is in the .layout (.zip) file when I unzip it. So how is it that the files that are saved in the .zip (.layout) file getting wiped out, completely obliterated, no trace? This is what I don’t get, they’re there, they’re part of the layout file, they shouldn’t be getting wiped out. What is it about layout that is purging these files? It happens if I leave a layout file open overnight, maybe it’s me losing contact with the server at a critical time (since the temp file is local, and the layout file is on the server) but the files are ON THE SERVER INSIDE THE LAYOUT FILE (in addition to being in the temp file - does autosave look for the temp files and can’t find them at some point?). Someone has to figure out this mystery with embedded/not embedded files.


#23


So… just fixed all my "red X"s (by clipping from the PDF printout of the file - lucky I had that), closed the file, unzipped the file, all my new clipboard files are in there, and yet, the reference for the file points to the temp file. I guess it takes all the files from layout, copies them to the temp file when opening, then references that while it’s open, and upon saving, it copies the temp folder back into the layout file? So at some point, when leaving it open, it can’t find the temp file, so it loses the reference AND then since the reference is gone, it deletes it from the layout file??? THEN if you still have layout open after your images have been purged, the BACKUP file then becomes this corrupt file, and you lose even your backup images. Anyone make sense of this?


#24

Hi
Same problem for me. Years of sketch up experience and use professionally with out this issue. Now ‘randomly’ it seems, I open layout files to find images greyed out with red crosses. References missing.
These images have been brought in a variety of ways. Copying and pasting from other layout files, inserted images, copied from an internet browser, and most worryingly from my scrapbooks. Scrapbooks I have used for years with no problems are now missing references. This is a new problem starting mid way through version 2017. Possibly with an update. Occurs on 2018 version as well.
I have worked around it as no one seems to have a workable solution yet. I copy images from older saved copies of the file which strangely have no issues. First I have to delete and purge the images from the current file. Then copy the old ones in. As you can imagine, I have usually made changes to the size and layout in the new file. This means repeating work and reduces Layouts effectiveness in a professional environment. Particularly when it usually happens the day before a deadline.
I am currently trying unlinking, purging and combinations of the two to see if I can properly embed the images. Just lock them in place. Testing is a bit haphazard as the file will work for a while then stuff up again.
Please solve this. If layout is to be an effective program, we need to be able to trust it.


#25

So another question I have- I assume this has something to do with us all working on a network, and the file and temporary file being accessed through a network. Is anyone here having a problem with a locally stored Layout and Sketchup file?


#27

Hello, I have just started experiencing this too, image links broken so document showing grey squares, but with images stored locally not across a network as txwoodworker mentioned. started happening after closing a document and re opened it, images were there yesterday. the mentioned file was originally saved as a different file name, then opened that new file and edited for a new client, leaving some pages with the same background info, all seemed fine yesterday? not all the images are effected, but most of them, never had this problem before, but now can’t seem to make any copy and paste work for pages needed to duplicate for different clients etc… did anyone find a solution for this other than rebuilding every page? thanks
sketchup pro 2018 layout v 18.0.16976


#28

Did you leave the LayOut file open overnight?

See this:


#29

Hi Dave, I may have! can’t remember now… and I am using mac MBP mid 2015 2.5 i7 OSX 10.13.6
I’ll have a read of the link, thanks


#30

But, with layout closed/opened the original file with the images opens up ok with the images all OK, then if I copy those images to the file with the grey squares, it pastes in with broken links, but if I do the same with a new file it pastes OK. so is the actual file damaged?
so do I need to create a new document once this starts happening? as images copied and pasted into this file from other documents seem to be grey now?
Thanks


#31

You need to relink the references instead of trying to copy and paste from a different file. Open Document SetUp>References. Select a gray box with the red X and then in References, click Relink. Choose the original reference file.


#32

Having to save every image as a file in a specific place slows down our work flow significantly. Plus, I’ve read about people having the same linking issues with referenced files too, so that’s not a panacea. Saying you can’t leave the file open over night, or that you need to have a reference file folder of all your pictures is a cop out. There’s an issue that needs to be hunted down and fixed.


#33

Did you read the post at the link I shared? He wrote:

The issue is being worked on. Until a fix is implemented, you can go on experiencing the problem or save and close the file overnight and avoid it.


#34

No, I am not on a network. Just a normal desk top.


#36

@tobyss, Delete the files/images then purge them. Document set up, references. Then you can paste/insert them back into the document without problems or making a new document.
I have found that they are often still viable in the back up document. So if you haven’t done too much work you can get lucky.


#37

Hi Again

I have just had the images removed from a file I worked on in November 2018. Was all fine until I opened it today and the images are all gone, red crosses in their place. Definitely did not leave it open for a long time as it is a small file. The old copies of the file (concepts and drafts) still have the images in place. So I doubt that the problem is temp files being deleted or problems with copy and paste or any of the reasons you have mentioned. I think you need to go back to the drawing board on this. Again, it did not happen to older versions of Sketch up. Just 2017-2018. I haven’t used 2019 yet, so we will see how that goes. This is a very concerning issue that does not seem to be being addressed with any clear plan. Very worrying.