Missing "combine textures" option


#1

I am using SU Make 2016 on Windows to create a custom tile texture. Initially I had no problem; I made the outline and filled in the different colors and then right-clicked and selected combine textures. But now I can’t replicate the process. I right click and there is no combine option. I have seen other posts about this in the forum, but found no definitive answer that would work for me. I have uploaded a file that has my original example plus its combined version (the brown tiles), as well as a green version that I cannot combine.combine textures.skp (497.4 KB)


#2

I rotated items to the ground plane,

BTW: I don’t know how anyone works in Parallel projection mode…

john


#3

So I rotated to the ground plane, and the result is the same (in fact I tried all possible orientations without success). I also tried checking soften coplanar as you did, but that also did not make a difference. I’ve tried closing SU and reopening the file, and I’ve tried making a new file. No combine option!


#4

Make sure you triple click so that all faces and edges are selected.
Combine
Note, if you click No to erasing the edges you retain the geometry in the original and create a combined material separately, whereas Yes will convert the original geometry to one face with the combined material applied…


#5

Looking at your model I see there is an issue, I can’t make it work either, I don’t know how @john_drivenupthewall has managed it. Perhaps it’s a Mac/Win thing.
Even copying your green one into a new model doesn’t work for me.
How did you create it, is it just geometry with colours painted in or did you do something odd with it?


#6

Making one face with texture Unique will let you combine all textures, again.


#7

I finally worked it out, I think.
If all your materials are just plain colours it doesn’t work. But throw in one Texture and it will give you the combine textures option. Which would explain why making one a Unique texture makes it work.
I guess they don’t think of colours as textures.

I may be wrong, but it’s the best I can come up with.


#8

Aha, you have hit upon it! My original brown tiles included some metal textures, but the green ones are just colors. This actually occurred to me at one point, but I neglected to test it. I added one little textured tile up in the corner, and combine textures is now an option. Thanks to all who commented!