Mescled Grey White Surfaces

Hello!

I’m new here and a new SketchUp user also.
My drawing seems to have changed it’s appearance and I don’t know why.

It seems to be displaying duplicated walls which could be front and back faces together, but I tried to delete one to check the change of the appearance and the wall was just deleted, as if it wasn’t duplicated.

I also changed all the View Options and couldn’t find any relation to it.
The shadows are given by Sun and it’s not 12:00 too.

May someone help me, please?

Thank you :slight_smile:

hello,strange… it does look like faces are overlaping ! If you send me the file, or a sample of it, I may take a look at it, to understand why !

1 Like

Hello Francisco,

Odd rendering effects can occur when the model is very far from SketchUp’s World Origin.
Tell us more about how the model was created, such as whether the model contains any CAD imports.

First confirm the Drawing Axes are in their default location, aligned with the World Axes.
Right click on any one of the red, green or blue Drawing Axes.
(Do this away from any part of the model)

In the Context Menu that appears, click … Reset
(If Reset is grayed out, then the Drawing Axes are in their default location)

Now, hit Zoom Extents
Does the model fill the screen or is it far in the distance?
How far is the model from the Origin?

2 Likes

Hi, Paul!
Thank you for your interest in helping me.

I coundn’t send you tyhe file because it only allows me to Upload a 3 MB file. Also, when I edit my drawing to send it to you, it doesn’t reduce it’s size. Not good signals, maybe SketchUp is not good for such big drawings…

I copied and pasted it at a new SketchUp drawing and then it suggested me to Correct errors, then it became “clean” of these overlaying walls. I guess this partially solves the problem!

The negative point is that now I cant “paste to the original coordinates” because there’s no tool for doing it there and the drawing is being pasted rotated.

Thank you!

1 Like

that’s because you have to purge your model. In sketchup if you have many components, the file won’t be reduced after deleting part of your model unless you purge it. (go to window > model info > statistics > purge unused) then save again after purge. In this very same place you can fix your model manually, so you won’t have to copy paste everything in a new file. is it working ?

(normally when you save your file, sketchup also makes an automatic search for problems)

Did you try Paste in place?

1 Like

Hello, Mr Geo!

I’m working with at the UTM 21 zone to the South hemisphere at about 6.5 milion meters away from the Original World Orign, but with the orign of the axes beside my drawing.
X/Long.: 644647 m, Y/Lat.: 6581707 m, UTM zone 21 S.

Now, as you asked about geolocation, I added the Geolocation and it still showing the same pattern of overlayed surfaces


My drawing have DXF files imported to it, such the base plant of each floor.

Thanks

hello, Dave.

I don’t know how to “paste in place”. Does it have this option like AutoCAD “paste to the original coordinates”?

simply go to edit > paste in place

Look to the top menus… Edit > Paste in Place

Again, @FranciscoWitt, after you Reset the Drawing Axes and hit Zoom Extents in the original model…
Does the model fill the screen or is it far in the distance?
How far is the model from the Origin?

Thank you, I’m learning a lot!
Here it goes
Parcial Drawing - SIRGAS2000UTM21S Datum.skp (594.7 KB)

Complete file here: Prédio E.skp (2.2 MB)

UTM zone 21S, Sirgas2000 Datum

Just like the others sensed, you have an object that is very very far from the origin. When you select all (ctrl-A) you will see the bounding box selection, one of them is huge. delete it and it will go back to normal !

in your full model, you have 4 times the very far object I told you about. here is the file fixed. I also did the manual fix I explained earlier.

Prédio E.skp (2.2 MB)

1 Like

Paul, it seems theres an error on my software installation because I rub the Search for Errors and it find nothing.

Otherwise, when pasting it to the original coorginates (Edit > Paste in Place) in a new drawing file it offers me to Fix Errors and then it’s all solved!!

Thank you, Dave!
Paste in Place command worked well. SketchUp suggested me to fix errors when I pasted it and it worked well!

(fixing errors manually wasn’t working)

You are using layers incorrectly, sketchup only uses them for visibility, they don’t separate geometry.
Have read here
https://help.sketchup.com/en/article/3000122

3 Likes

Happy that helped. One thing you’ll learn is that clean and efficient modeling as you go is rewarded while sloppy modeling will punish you by making you work harder to get things accomplished.

1 Like

I really don’t know why the DXF blocks toke this dimension.
Thank you a lot!

Hello, Box! Those tips are good, essential, in fact. Thank you so much