Materials and Objects Disappearing When Orbiting or Panning (Not Clipped or Missing Faces Issue)

Hi Everyone,
I hope you all are well. I was wondering if someone could help me with an issue I am facing in SketchUp. When I orbit or pan, my materials becomes plan colors and also objects disappear. I have attached two videos for references.

After research, Clipping and Missing Faces are the related issues popping up on search but I do not believe this is that.

I would really appreciate your help.

Thank you!

This is normal behavior. SketchUp simplifies objects during orbit to speed up graphics when necessary. This happens when there there are a lot of polygons in a model, or a lot of complex transparency or in the bottom case some face me components are being recalculated to face the new camera direction. SketchUp creates a proxy of the more difficult things to render during orbit if it is struggling to render on your machine, then re-renders when you stop orbiting.

1 Like

Thank you! How can I fix this?

What do you have for a GPU? Processor and its speed? Your profile is incomplete. Is this a desktop, laptop or something else? The solution is dependent on the answers to these questions

I have a HP laptop (6 years old), i7 Processor, NVIDIA G Force 740m. Does this help?

With that hardware there may not be too much to help things. One possibility is go to the Nvidia website and get the latest driver offered for your GPU.

Okay, Thank you very much. I really appreciate it.

It’s amazing to think that i7 was released as long ago as 2008! 740m was released in 2013, and so was probably the best you could have got at the time.

There is a chance that you are only seeing one of two GPUs, and that SketchUp is using the other one. See if you are able to follow these screenshots, starting by going into Graphics Settings. Change from System default or Power saving, to High Performance. That will set SketchUp to use the best GPU it can find.