Matching scale when importing .dwg topographic

Hello SU Pro friends!

Here is my latest dilemma: I am working on a permit set for a new house. A survey was done of the entire multi-acre property prior to amendments that had to be made to the driveway. A second, smaller survey was added at my request following on that work being completed, and a bunch of excavation being done at the eventual building site. The surveying company was kind enough to send me a .dwg CAD file of the whole thing in 3D with contour lines, the location of the proposed building, etc. - very useful stuff except…

1.) for my purposes, I only need a small part of this topography (like around 250’ x 250’) to create a flat
site plan sheet showing the proposed location of the house, and
2.) I need an even smaller area to create a contour tag to sit the model of the house in for some pretty perspective shots.

The problem is that when I import said topo, it’s a large area on a very small scale relative to the model I’ve already drawn, and I have no idea how to MATCH the scales. I know the scaling method, as well as importing using correct units (map is metric, model imperial), I just don’t know how to get them to the same scale so I can just stamp the foundation on to the terrain? Also, I’m looking for any handy tips on how to quickly edit out the extraneous parts of the topo.

(here is the project I created to practice in):

FREEBORN (Joey’s copy).skp (7.2 MB)

Thanks in advance!

Big Beaver

You need to identify some topographic features in the dwg file that you can match to real features on the ground, or known measurements.

Then use the Tape Measure tool to change the scale of the dwg file (imported into SketchUp) to match the known dimension.

@john_mcclenahan has pointed out the right tactic, I’ll just elaborate a bit. You can resize the terrain in a separate file then import it, or you can place in inside a group or container and resize it inside the container so that the house geometry is unaffected as I have done here. Either way you will need to know the correct real world dimension of at least one edge in the terrain. I the open the group for editing and invoked the tape measure, hit the appropriate modifier key for Mac which is option to ensure the tape measure will is not set to make guides, the little plus goes away. Then measure one known edge, a random dimension will appear int he VCB lower left, then simply type in the correct dimension for that edge. You will be asked if you want to resize the group, say yes. I guessed at 200’ for the one long edge, but you will need the correct dimension.

If you cannot get a single true dimension you may be able to discover what the native units for the terrain are and import at the correct scale by starting in a new file and experimenting with the import units, but the above method is the surest and quickest.


When importing a DWG, open the Options dialog (button on the import file dialog box) and make sure that the unit setting there is set to match the unit your surveyors used in their file. The default unit is Feet so from your description it appears to me that you imported using Feet or even a smaller unit.

Hi! Thanks for the quick response! This looks to me like exactly what I need to do, and there is a very specific known dimension in the imported topography I can use for scaling. My problem was keeping it separated from the house model, which you have done with a “container” (I tried is as a group and a component, exploded it, no dice). Could you just clarify how you actually made that container? I feel like that will also be helpful when I want to chop off the parts of that topo I won’t need (which is most of it).

I never tried it as group, that may be the step I missed?

Group or Component, either will work. So, select all the terrain geometry, right click and choose make group (or C). The crucial step is you need to then open the group for editing with a double click (or right click and choose edit group). Then you are performing the resize on only the things contained inside that group.

That did the trick, I must have just been repeatedly skipping or missing something. How would you go about trimming all the unneeded topography?

1 Like

Glad that worked. I would probably trim unneeded terrain with a combination of careful selection and perhaps the eraser tool.

Yes…sometimes I’m a little slow on the uptake… it’s 3D, I can work my way up vertically.

1 Like