Match Photo issue. All scenes model axis moved universally at once... with no way to return

Match Photo issue. All scenes model axis moved universally at once… with no way to return. Current model file is SU22 (edited… I typed 2021 originally. Oops)

I’ve been working a project that has had the same issue numerous times, which is why I have made so many versions of it as it progresses. And the latest version, even the backup was effected so there’s no return to the state prior to the issue.

I’m using Photomatch on about 12 or more different scenes, all reference photos for the model in different perspectives. All photomatched scenes aligned perfectly…

And then, while editing a component, or importing a section, or (and I have NO IDEA what) not sure… the next time I click a photomatch scene… the model is off in scale and position. Then I confirm and sure enough, every single photomatch scene is off to the same degree.

It’s not as random as I first imagined as now it’s a constant issue that is causing havoc yet, there doesn’t seem to be any rhyme or reason specifically for when it happens. One thing for sure, using the current method, when this occurs, I have to go back and re-align each and every dang scene and the settings seem not to remain the same with the axis/FOV. So much work lost… so much work to repeat just to get back where I was when this issue repeats.

I’m including some images to show how in numerous (basically all) photomatch scenes, the model is thrown out of position.

Any idea how, when and under what circumstances this is triggered? How to avoid it? And how to RETURN or get back to the original position of the model in the scenes without editing each and every photo match scene AGAIN?



I too have had weird photomatching resetting
I had to save out my model . Start a new file using photomatch and set up the axis etc again.
Not ideal but i had no options i could think of .
I tried deleting the scene tab and rematch but same issue happened again… grrrr

1 Like

It would be SO HELPFUL if we could export photomatch scenes (with the photomatch image reference) and camera position/settings to be able to have an anchor, solid, reliable reference point to import if needed.
I haven’t been able to once export a photomatch scene, and without the ability to copy/paste the photomatch scene in a new file… it’s terribly fragile modelling at best. Meaning, Yes, I can duplicate the file… but, the archived save can’t export photomatch scene data to import into newer version of model.
I love photomatching. But, I hate that I begin to fear if I burp, sneeze or cough in the real world, the model axis and scale is going to be thrown out of position in the SU world.

1 Like

Yip… it is a pig when it comes to matching position jumping like that. I had that at the weekend but im feeling. What if it jumps again? This animal needs tamed!

Exporting out photomatch scene views with axis position would be great. Eneroths view memory has saved a heck of time for me on large projects before would be great if photomatch scenes tabs could be incorporated also.

1 Like

Wow, this is upsetting. I’m just moving from 2020 to 2022 in the past week or two and haven’t done any Matchphoto with any version since 2020. I did a post once on how to replace the photo and keep the rest of the Matchphoto settings, but I’ll bet that won’t solve the problem. Advanced Camera Tools might be one help. Another might be js Camera Line. Once you have a line as the center axis of the camera view, you could use the set eye tool to recreate the camera setup.

1 Like

Agreed. It’s like Photomatch was a brilliant idea but, there’s just not enough people using it on large projects for extended amounts of time to require further/greater dev. I remember using photo match for years for “beginnings” of projects and once the model “part/View” was completed, the rest of the scenes would be nondependant or not needing to ever revisit that photomatch scene.

However, this project is photomatch dependant on numerous image sources and progressively… Match Photo BECOMES the problem. On this project alone, this is the 5th time I’ve had files get screwed up in this same way… only because I NEED it to work right from one perspective to another and be able to constantly cross reference. But, this hiccup is consistent enough to force me to create more than backup, but version archives for every advancement of the model. Unfortunately, I’ve been working for 5 days without making that extra save, though I do have the backup. As the backup is compromised, this particular weakness becomes obvious and I’m now quite surprised I never heard of this in the Facebook SketchUp groups. No answers there.

I’m simply thinking that too few people use PM to such a dependent agree to expose the problem.
This needs to be fixed though. It’s just “one” of Photomatch’s Achilles heal. There are several but, this one?!.. takes the cake.

No, plugins won’t fix the inherent freakout (I believe) because whatever the trigger is, it’s benign operations, nothing consistent to put the finger on to replicate the issue.

Another problem is that once this appears, no amount of “undo” will bring it back… in my experience.

For example, if one edits a photomatch scene and gets it REALLY, REALLY, ALMOST perfectly set, and then saves… and then chooses to edit the scene again, there’s no abandon ship, escape, return, undo to go back to the saved scene. It’s ruined… have to start over. That headache alone is such a pain in the backside requiring numerous duplicate scene creations just to save any progress made in previous scene.

I know that there are plugins that inhibit Photomatch from working properly… but, these programmed, inherent tool manipulations, once screwed up… can’t be fixed by a 3rd party extension and SketchUp doesn’t offer greater control for such editing.

… unless I’m wrong and someone has a VERY good surprise for me. :slight_smile:

Yes, that’s true. Is this jumping problem new since version 2021?

My suggestion for js Camera Line doesn’t actually solve the bug, but it gives you an actual element of geometry in your model that marks the centerline of the camera view which could help rebuild the scene when you’re desperate.


Not only that… today’s snafu was about the time I was copy/pasting edited groups and components from a workshop file. When everything was edited and I was happy, I was a good boy and pressed save. We learn, we are taught, by experience we KNOW to press that save. And, unfortunately, never test the Photo Match scenes to see if they screwed up before the save.

And have you tried copy/pasting a Photomatch camera with Eneroth’s camera memory into a new scene and tried to import the same reference photo and have it align?! I gave up. There’s just too much lost information for it align to the work done in the first correct scene. I’ve tried also placing a Advance camera tool camera in the photomatch scene. Copy it and paste that camera in a new file scene thinking I could just import the reference photo and have it match. Nope… or no luck for me.

These become essential use operations that NEED to have a solution. PM is sick and needs some good ole fashion chicken soup remedies to get it working on a professional level as a “real” tool beyond it’s first intent.

1 Like

Post edit: Current model file is SU22 (by mistake, I typed 2021 originally. Oops)

I haven’t tried Camera Memory on Match Photo. I have tried Advanced Camera Tools, but I struggle with that set of tools too.

I gave a talk on Match Photo at 3D Basecamp last September. Lucky me, I guess, I’m a laggard and have been stuck on SU 2020 up until now.

Post edit, I’m not using SU21.
To be honest, I never used Photo Match enough to notice this problem prior to SU22 and SU23 as the projects I built using it in earlier SU versions didn’t require more than the one scene/image as a starting point and rarely cared to even look at that beginning scene once the model advanced. Make sense? However, I’m almost willing to bet, with the repetitive way that it’s operating, it must be par for the course and that eventually, when working with PM on a single file long enough, this will occur.

@jamsog, I’m assuming that your experience this weekend is with the latest release/version of SU23, yes?

As for SU21 and before, I just don’t have enough time with PM to confirm one way or another without doing some tests.

I’ve done a whole lot of Match Photo projects over the years, many with multiple views and kept the setup throughout the project because it provided the surroundings for final presentation views. I don’t think I’ve seen this before, but as I said I’ve been lagging behind and only just started working in 2022 this past week or two.


Then, if this is typical behavior, you should have perhaps experienced this prior to SU22. Perhaps it is actually a new thing since SU22 onward. Interesting.

That’s what I’m wondering, or possibly is some extension you guys have might cause it. That’s really hard to figure out.

1 Like

Hello, I’ve had the same annoying issue from 2022 version. I did not have it with 2021 version. It is unpredictable, I’m glad I don’t have to use photomatch that much


And here I was just two weeks ago deciding, “Yay, now I can finally upgrade from 2020” and figured I’d just jump to 2022. Maybe I should switch to 2021 and hang there as long as possible.

1 Like

Or… just play along for a bit and see what happens… while keeping a backup and a copy of it updated more than periodically to open in SU20 or SU21 to see if you get the berserker there. It would be interesting to have more people chime in here with their experiences and tests comparing versions, hopefully isolating that this is indeed a SU22-23 problem.

1 Like

@jamsog, I’m assuming that your experience this weekend is with the latest release/version of SU23, yes?
Or was this in SU22?

1 Like

Yip only in 2023… photomatch i have used many times and trained it to many clients over the years It is a vital feature and saves alot of time
online video tutorials dont give it credit because each and every one of us have to learn how to take the best pics and or manipulate imagery to.then photomatch. Im sure you know this however seeing such a bug like this. Its a concern.