Manually entered dimensions changing to the line length

Hi All,

may have been touched on before but searching doesn’t come up with an answer, and its causing me a lot of grief.

I notice that some of my dimensions, some are manually edited, default to a length, usually much smaller than the actually dimensions length, for example 1050mm I notice changed to 87.

After looking more closely at this I noticed that the 87 is actually the length that the line tool says the dimension is, and it is replacing my dimeson / the sketchup scaled dimension with the 87.

is there any solution? see below for an example where the dimension is 1050mm but it can sometime default to the length in the bottom right corner 87mm.

I expect when you edited the dimensions they became disconnected from the model and are now showing paper space. Or perhaps you changed the Scale setting for the dimensions from Auto to something else. If you share the LO file so we can see exactly what you’ve got, it would help us help you.


All my dimensions seem to have a different line tool length and some dimensions change to the line tool length, not sure why they do it on some and not all.

What do you mean by this?

Why are you having to manually edit these dimensions in the first place?

when drawing a line using the line tool, the measurement of the line doesn’t relate/scale to the measurement on the drawing when using the dimensions tool. for example the dimension tool might say a length is 1000mm but the same length drawn with the line tool might say 86mm.

As well as that I have noticed some dimensions change themselves (not sure why) to the line length.

some times I add a manual measurement to the dimensions if they are off by a couple of mm or I just want to change them without changing the SketchUp model, I know its not ideal practice but shouldn’t bear any relevance to this issue?

If you are drawing a line with the Line tool in LayOut the line’s length will have a paper space length. It will have no relationship to the model in the viewport. You could use Scaled Drawing and choose the scale you use in the viewport before drawing the lines. Then when you dimension them they will dimension correctly.

One of the dimensions I see that you’ve manually edited is the 100 mm dimension from the center of the plate on the wall to the center of the mount for the towel warmer. Did you model the towel warmer or get it from the 3D Warehouse? A simple fix of the model makes your work in LayOut a lot easier. Here I made a couple of simple fixes to the towel warmer. The 100mm dimension show selected is a connected to the model and doesn’t require editing to make it read right. Maybe that isn’t all that important to you though.
Screenshot - 1_14_2022 , 9_56_46 AM

By the way, it would also make your work easier if you make sure tag usage is correct. All edges and faces should be created and remain untagged. This is what I found in your model.
Screenshot - 1_14_2022 , 10_35_25 AM
And purge unused stuff once in a while. This reduced the file size by 40%.
Screenshot - 1_14_2022 , 10_36_09 AM

Thanks for that,

Do you know why a dimension value would change from the SketchUp measurement (or a manually entered dimension for that matter) to a paper space length measurement ?

A dimension will change to paper space if at least one end is not connected to the model. If you are double clicking into dimensions to edit text be very careful so you don’t accidentally move an anchor point.

My preference is to make the model right in the first place so I don’t need to manually type dimensions in LayOut and so when a change order shows up, I only need to update the model and then update the reference in LayOut. No need to then go chasing around the LO file looking for dimensions to fix.

That’s great thanks,

So lesson to learn is make SketchUp model with measurements correct before Layout so dimensions in Layout don’t have to be manually changed which could increase the risk of wrong measurements.

By the way, it would also make your work easier if you make sure tag usage is correct. All edges and faces should be created and remain untagged. This is what I found in your model.

Would you mind expanding on the above a little? do you mean components and groups can be tagged but not actual faces and edges within them?


Yes! The more accurate the model is, the easier it is to work with down the road. Not only in LayOut but in SketchUp, too. If the framers are sloppy when they frame up a house, everyone who comes after them has to work harder to make up for the framing.

Yes. Only objects (groups and components) should get tags. ALL edges and faces should remain untagged and Untagged should always be active. This means you are never chasing the tags like you have to chase layers in other applications and you won’t have things disappearing unexpectedly when you turn off tags for other things. If you follow this “rule” you don’t even need to know what tag has been given to a component or group when you edit the geometry inside it.

One thing I noted with the towel warmer at the point where it meets the wall, those circles were not drawn on axis. That can lead to dimension errors. There’s also a lot of excess geometry in it that thing. Simplifying components where possible will help to keep file size down and performance up. That’s why I asked if you modeled it or got it from the 3D Warehouse.

Thanks Dave,

That makes sense now,

The towel warmer is a warehouse model, so looks like it wasn’t modelled to axis!

1 Like