Malfunctioning pencil

When you click on the pencil set your 1st end point - click to set the 2nd point it doesnt give me a single line, I get a fan of lines.

Alas, that sounds like a graphics issue. Your UHD Graphics 630 (an Intel Integrated Graphics) isn’t recommended for SketchUp due to issues like this. You could try downloading the most recent driver from Intel (NOT from Windows or your computer manufacturer) and see if that helps.

1 Like

Some integrated GPUs can leave you with a blank scene, and that is cured by turning off Use fast feedback in Window/Preferences/OpenGL. Some integrated GPUs are better than others, and if that option is turned off you can get artifact lines.

So, go into Window/Preferences/OpenGL and check the box next to use fast feedback.