"making unique" instead of "unlock all" when I modify?

In my research phase, I work on multiple iterations of a project on the same page.
My method is to duplicate the modeling to work on the evolution of an idea.
As I’m using components, I use the locking of previous objects to avoid damaging these ideas.
The good thing is that sketchup tells me that copies are locked even in deep nesting. I then choose the Make unique option to modify the object and avoid damaging previous ideas.
The (small) problem is that the default option is “unlock all”, whereas I only use “make unique”, so I systematically have to click on the right choice, which bores me in the long run.
How can I change the default choice to “make unique” and only have to press “Enter” to validate?


Sorry, the screenshot is in French only.

tab + space

pressing enter will pick the standard blue choice.
pressing tab will cycle through the 3 choices. pressing space will pick the current choice

so in your case, press tab once, then press space.

(works in any similar window in mac os, enter for the main choice, tab + space to choose another one :slight_smile: )


Tab space is a good tip, I didn’t know that.

Or, you could change your workflow and copy/paste each new iteration into a fresh file. Then no locking, and no make unique ever required again. You can still keep multiple files open.

Thanks for your feedback.
I’ve tried various keys like Tab or the arrows. But nothing moves. The selection remains stuck on “unlock”.

I don’t understand why it works for you @ateliernab and not for me :confused:

In my personal search phase, I like to have my various tests in front of me.
On the other hand, I create new files for each evolution when I discuss with my customers.

check mac os preferences, in the keyboard section, is keyboard navigation enabled ? I think apple turned it off by default a few years ago, but I’m technically on an user account that could be traced back to 2005 so… I might have carried the old preference with me ^^"

Ok, thank you @ateliernab. Your tip is the right one.
On my old macos bigsur, the setting is in Preference > Keyboard > Shortcuts > check box at the bottom of the window.

1 Like