macOS Catalina and SketchUp

It did work. No issues except for trying to open an older version of Sketchup. But a few tries and it opened.

Hi Milo, did you find any roadblocks after a few days of use? Interested in the 2019.2 version of Sketchup Pro Classic

The (developer) beta-7 release of Catalina was made available today (click here for the release notes). As with any beta or pre-release software, users are advised to exercise caution when upgrading their OS.

hi how did you get passed the security?

Stephen

I think that he used my August 4th suggestion:

One thing that seems to happen is that you right-click, Open, and still nothing happens. If that’s the case, open System Preferences and look in Security & Privacy, General. You will see a message in the bottom area asking if you trust this DMG.

I’ve been using -right-click > Open without any issues.

Apple released the beta-8 version yesterday, and various websites are saying Catalina will see an October release.

I can use Sketchup but cannot use layout in Catalina OS

What happens when you try to run LayOut?

Any new info if we are going to be able to use SketchUp and Layout with Catalina?

We continuing our testing with the beta versions of Catalina. Hopefully Apple will announce a release candidate build soon.

Catalina was released today! Would Sketchup and Layout work? Sorry for insisting so much with the topic, but Catalina has features that are very important for my workflow.

Thanks for the update.

Gus

SEE THIS POST

1 Like

Hi having updated to Catalina, working on Skp file saved to Google drive will now Not save ? worked fine before. Haven’t tried it with iCloud yet.

What happens when you try saving or accessing a file from Google drive?

what happens if you check to update SketchUp ([menu]SketchUp->check for updates

Hi
file opens fine from Drive but when trying to save set an error message’ Could not be saved File is locked’ then another ’ you do not have permission to save the file. Spoke with Apple and Google and both think it’s an issue with SketchUp and Catalina.

Big Guys blaming the little one…I would not go against them…
Who did you speak?:smiley:

That’s not unique to Catalina. If you do a search here you’ll find others have reported similar errors. Note that saving models directly to cloud is not recommended as it can lead to corruption of the model.

2 Likes

In general, we do not recommend saving anywhere other than a local physical drive (no cloud, virtual, or USB drives). Getting errors while trying to save to something like Google drive has always been an issue, and should not be how you are saving files.

4 Likes

Hi Thanks
yes not normally a practice I use but in this instance it was on a shared drive.
I have reverted to saving locally and walking away from this little problem …

1 Like