Mac Toolbar - A small annoyance

Good Evening

Took me ages to think of a title for this.

I’m thinking this is a really simple problem, and I’m missing something obvious.

So, Pro 2018 running smoothly, (very impressed. It’s definitely a lot quicker than 2017), and I’ve customised and setup the top toolbar as much as is possible on a Mac.

One of the tool sets I’ve added to it is the Skalp one. All good and runs perfectly.

Only slight annoyance, is, when I click on the Skalp Tool, the Skalp floating toolbar/box then appears as well, which I don’t need as I’ve added those two tools to the main toolbar.

I’m assuming I’m missing something really obvious, to stop the floating toolbar appearing.

Thoughts and suggestions would be greatly appreciated.

Kind regards


Michael, I’m not a Skalp user so I don’t know the answer for sure but look in the Tools, Window, and Extensions menus for a Skalp entry. There may be a place to make some preference settings for the UI. Thom Thom and Fredo6 have both done similar things for a bunch of their extensions.

Thank you @DaveR, I’ll have a look.

Could have sworn I looked in there, but I’d been modelling all day, so my eyes were probably knackered with looking at the screen for so long.

I’ll have another look tomorrow.


1 Like

I posted about exactly this general issue recently. See here:

Hi @simoncbevans

I’m hoping the Skalp one has an option to just turn it off. I did enable it before I customised the toolbar. It only appears when I activate Skalp from the tool icon I’ve added to the main toolbar. It doesn’t show on Sketchup Startup.


give @Guy a ping…

sounds like a v tb.restore issue…


It’s not a huge problem to be honest. Just a minor annoyance.

Just double checked and there is no option in the ‘Extension’ dropdown area, or anywhere else that I can see, to disable the Skalp toolbox/bar popping up.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.