Lost a SketchUp Web project after installing and logging in on the desktop program

I’d gained some experience in Photoshop and AutoCAD some years back, and was hoping I’d be able to transfer some of that knowledge with the features in the SketchUp program. So I started a project on the free browser version first, while deciding if I wanted to commit to the full membership.

I’ve been working on it the last several days straight, and yesterday was recommended to install the desktop program instead, as I could take better advantage of the features, etc. Upon installation, I logged in via my Google account, as I had with the browser version, and was prompted to start a 30 day trial - I’ve since been unable to recover that project, as the trial account became a different “personal account”. In my account management page, I can see that I have two personal accounts, but I can’t get to the project I’d worked on and saved online.

So far I’ve tried:

  • logging out and then logging into the browser version to see if it would pop up with the most recent project that I used with that version
  • checking to make sure I didn’t accidentally log in through a different email - I had no sign of account creation from my other email
  • since I can see that both “personal accounts” are shown, I have no option to open up the previous account to open and save the project elsewhere
  • I can’t seem to find a way to cancel that trial account to recover my first one… double sad if that were my only option, and I’d have to miss out on the trial

I’m not sure if I’ve missed anything else, but any help would be so appreciated!

Go to connect.trimble.com and sign in.
There should be a project called ‘SketchUp’ where you’re files reside.
The home page of the web app only displays the ‘recent files’
Sometimes, when accounts get updated or the browser get refreshed, they get lost.

Found it!

Thanks so much! Many hours of work un-wasted again, heh.