Losing functions

Using Sketchup Free I’m seeing an increasing loss of function. Examples are that within the model there is no response to the keyboard. It still accepts typed dimensions but I can no longer type “R” for a rectangle, “T” for tape measure, the space bar no longer takes me back to the pointer and Ctrl+Z does not undo. When I make a circle or rectangle and push I have to mouse click on the push tool instead of using “P” on the keyboard. Often but not always, the top surface disappears when I start to type in a distance to push.

The computer is a laptop with a Core i7 processor and 16 GB RAM, lots of empty hard drive space and in Intel 4600 graphics card with current drivers installed. It’s running Win 10 64 bit. I see exactly the same problems on another computer running 32 but Win 10 using a different mouse and its own onboard keyboard. These problems started a few months ago but seem to be getting more extensive. The decreased functionality is making it useless. Any ideas?

Are you using Edge for the browser?

To add to Dave’s question, if you are using Edge, is it v44 or v81 (or later)?

v44 has various keyboard issues, v81 doesn’t have those issues.

Yep, using Microsoft Edge 44.18362.449.0on both computers which I have avoided upgrading. I’ll set a restore point and then update.

“Jubilation! She loves me again!” The Edge update seems to have fixed everything. Don’t know why I use Edge for SketchUp. I just do. Everything else is done in Firefox.

Thanks!

1 Like

One of my existing models is a fairly large file for me as a home hobbyist at 13.7 MB. It’s my new workshop with most of its tools: table saw, drill press, band saw, dust collection. miter saw, vises, workbenches, welding equipment, metal lathe and so on, mostly from the 3D Warehouse with some of my designs as well. It loads maybe 30 times faster than it did with the old Edge. The 3D motion is also greatly enhanced. It also exported a copy to my local hard drive for the first time. It would never complete with Edge v.44.

1 Like